cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to retain RTC contents using Vbat (STM32 NUCLEO-F401RE)

bhondoo
Associate

I am using the internal RTC and powering the board through Vin, also connected is a Li ion battery to Vbat. When disconnecting Vin supply, I am observing the following:

 

1. The Vbat is actually powering the entire board and draining quickly, contrary to my expectations of the board entering Vbat mode and powering only the RTC and LSE.

 

2. Contents of the RTC are lost.

Please suggest what can be done. I have dug into the reference manual and application notes, however I seem to be missing something. Note that I am using a Nucleo board. Thanks.

3 REPLIES 3
Peter BENSCH
ST Employee

Welcome @bhondoo, to the community!

The NUCLEO-F401RE uses the board with the  MB1136 as a basis. If you look at the schematics of this board, you will notice that the jumper SB45 is set by default, which connects VBAT to VDD. Unsolder it, connect your battery to VBAT/VLCD/VDD (CN7.33) and your problem should be solved:

MB1136_VBAT_SB45.png

Good luck!
/Peter

In order to give better visibility on the answered topics, please click on Accept as Solution on the reply which solved your issue or answered your question.

With VBAT not connected to VDD, I've seen similar symptoms when VDDA was not connected to VDD.

Explanation above by @Peter BENSCH sounds more likely in this case, though.

JW

Check and install LSE to maintain time keeping and don't reset RTC in your startup process 

Tips, buy me a coffee, or three.. PayPal Venmo Up vote any posts that you find helpful, it shows what's working..