Showing results for 
Search instead for 
Did you mean: 

STM32F767ZI on external power supply is stuck until reset button is pressed


Hi everyone,

I have developed a software using mbed OS on a Nucleo-144 board (STM32F767ZI), and everything works well.

Now, I am powering my board from an external power supply, and I moved the JP3 jumper to VIN position.

However, the board is stuck. The program correctly starts only if:

  • the board is connected to the PC through a USB
  • the reset button is pressed

I read several posts, and I tried all the proposed solutions: update the ST-Link firmware, place a jumper between the NRST and 3V3 pins, also removed the SB111 0-ohm resistance between NRST and RST, but nothing works.

One interesting thing I have is this: if I manage to start the program (using USB connection or reset button), powering off and on again the board in a very short amount of time make the nucleo works fine. However, if I power it off and wait a few seconds, then the board is stuck again until the reset button is pressed or USB connection provided.

Any help on this?

Thank you very much.

ST Employee

Hello @MMaro.2​,

Please make sure that both SB3 (3.3 V regulator) and SB111 (NRST) are OFF (ST-LINK not powered)

You can find details in UM1974, section 6.4.2 External power supply inputs

To give better visibility on the answered topics, please click on Accept as Solution on the reply which solved your issue or answered your question.

Hi @F.Belaid​, thank you for your answer.

I removed also the SB3. Unfortunately, now the program doesn't ever start, even if I connect the USB or press the reset button.

Do you have any other suggestion?

Thank you very much.


I think I've seen something similar, it might be that the extra ST-Link-STM32 which is controlling that reset line is causing the trouble, so look for some jumpers / solder bridges in the NRST path between ST-Link and the STM32F7.

Make sure BOOT0 is pulled LOW and not left to float..

Tips, Buy me a coffee, or three.. PayPal Venmo
Up vote any posts that you find helpful, it shows what's working..
Senior III

At nucleos boards, clock signal is generated by integrated ST link. It is possible, that ST link starts later then when is powered from USB and clock signal is delayed. Main MCu can detect failure oscilator and go into error loop. Try debug.

Chief II

As I have an unmodified NUCLEO-F767ZI attached to my PC, I updated the ST-LINK on it to the latest (V2J40M27) version and took some measurements. Here is an interesting picture:

0693W00000VOQI3QAP.pngCH1 is VDD for the main MCU and CH2 is HSE clock from the ST-LINK's MCO. The clock starts 35 us before the VDD starts rising. The lone clock burst on the far left is 4 ms after the USB/power (ST-LINK) is plugged in. NRST line is held low almost all the time and is released 50 ms after the third (and last) "VDD on". Though there is also a 3 ms long spike on NRST 50 ms after the second "VDD on". I guess those "VDD on" intervals could also be dependent on a USB host. If the board is powered from a simple USB power supply, then there is just a single normal "VDD on", but it happens after a 2 s initial delay.

It should be noted that by default the HAL/Cube applies a 100 ms timeout for HSE startup. Therefore, if the board is powered externally and NRST is disconnected from ST-LINK, the code will definitely fail on power up. If the goal is to use the clock from ST-LINK, then it's better to leave NRST connected also. And update the firmware because, for example, the V2J38M27 doesn't release the NRST without PC at all.

P.S. What do you guys think about that "triple start"? I do understand that there is a bootloader etc., but still it seems to point that the firmware is written by the same HAL/Cube geniuses...

My reading of the Nucleo manual is that the default state of BOOT0 is that it is low, so in this case there is nothing to do, is that correct?

Associate II

Experienced the same thing on a NUCLEO-F429ZI.

Due to the "special" startup procedure of the ST-Link (VSJ40M27) I haven't been able to run the MCU within a decent startup time (less than 1 second) from external power source (by timeout before setting HSE as clock input).

And because the NUCLEO developers decided not to assemble oscillator X3 and caps C37 and C38 it's not possible to use the normal HSE oscillator X3 by configuring the solder bridges SB8, SB9 and SB149.

So my onliest option so far for using the NUCLEO-144 boards with an external power source is to use the internal oscillator HSI to get a decent startup time. Any other options there?