cancel
Showing results for 
Search instead for 
Did you mean: 

ST-Link on 32L0538DISCOVERY doesn't connect to PC

Toximik
Associate II

Hi,

i have bought 3 pcs of STM32L053 Discovery kits and the user USB is working fine with preload demo, but the ST-LINK USB connects to PC as USB Composite Device even if i have download and install the last ST-Link drivers from st.com. I have tried different ports, different cables, also tried reboot computer, reinstall drivers and unfortunatelly nothing helps. Tried all 3 boards and all behave the same.

Other Nucleos (F401, L452, ...) and Discovery boards (L152) are working properly and without any problems.

I kinda desprate.

Thanks for help.

Tomas

6 REPLIES 6
KnarfB
Principal III

I have no specific advice, but composite device is nothing bad. When using USB Device Tree Viewer with a working board/driver one gets a composite device with 3 child devices:

  • ST-Link Debug (STMicroelectronics STLink dongle)
  • USB-Mass Storage Device
  • STMicroelectronics STLink Virtual COM Port

Do the USB VID/PID differ?

hth

KnarfB

Toximik
Associate II

I get only USB composite device with yellow triangle and no other device appears. ST-Link utility does not see the ST-Link etc.

Uwe Bonnes
Principal II

Check different cables, check on different ports, check on different PCs.

Toximik
Associate II

@Uwe Bonnes​  I have already tried different cables, ports and computers. Nothing helped. :\

Imen.D
ST Employee

Hello @Toximik​ and welcome to the Community 🙂

Check that the setup of the jumper is correct.

Try to follow this FAQ: USB device not recognized

When your question is answered, please close this topic by choosing Select as Best.

Imen

When your question is answered, please close this topic by clicking "Accept as Solution".
Thanks
Imen

Hi @Imen DAHMEN​,

Setup of jumpers is correct and I don't thing, that any jumper on STM32L053 board have any impact on link between ST-Link and computer.

FAQ is not related to my problem, because I don't have problem with my program, but with the program inside ST-Link chip (STM32F103xx), which doesn't connect to the PC.