Showing results for 
Search instead for 
Did you mean: 

Nucleo -G031k8 Board Stlink issue


STMicroelectronics ST-LINK GDB server. Version 7.5.0
Copyright (c) 2023, STMicroelectronics. All rights reserved.

Starting server with the following options:
Persistent Mode : Disabled
Logging Level : 1
Listen Port Number : 61234
Status Refresh Delay : 15s
Verbose Mode : Disabled
SWD Debug : Enabled
InitWhile : Enabled

Target no device found

Error in initializing ST-LINK device.
Reason: No device found on target

ST Employee

Hello @Anurag and welcome to the ST Community 😊.

Could you check another USB port and try using a USB data cable not just a charging cable.

Best Regards.


To give better visibility on the answered topics, please click on Accept as Solution on the reply which solved your issue or answered your question.

sir thank you for your reply but i have tried with multiple usb port and usb cables but it still not detecting the stlink and show the same error.

Chief II

From error message "No device found on target" -> st-link cannot find target cpu G031 .

So use stm32CubeProgrammer , connect : under reset - and show screen, what it telling.

Maybe you have to erase it first or set flash to not protected sate.

But be careful, setting the option bytes wrong, you can "kill" the cpu , you can no more access it then !

Read in rm first about option bytes, so you know, what you do !! 

If you feel a post has answered your question, please click "Accept as Solution".