Showing results for 
Search instead for 
Did you mean: 

STM32Cubeprogrammer no target found

Associate II

I recently got into dual core mcu (STM32H755ZI) programming and made the common mistake of not configuring the cores correctly and now the board would not connect (I used the STM32CubeProgrammer to flash one of the two .hex files into the device memory). I have tried the suggested process by Adam BERLINGER on the forum but for some reason it did not work and after hours of trying the same thing over and over I found that the following process works for me.

1. Connect the NRST pin to GND
2. Connect the board to the computer (while the STM32CubeProgrammer is not on)
3. Start the application
4. Un-Check this option


5. Try to connect and once the following error shows exit the programmer application and keep the board connected


6. Relaunch the programmer application (with the board connected and the NRST pin held low
7. Press connect and disconnect the NRST pin within one second (I do the Zero, One and release movement)
8. The board Should connect (It worked for me for every board that I have tried, STM32F7 and STM32G4 Nucleo boards)
9. Perform a Full Chip Erase

And you should be good to go 🙂

My system info, Windows 11 23H2 KB5036980 and STM32CubeProgrammer v2.16.0

ST Employee

Hello @ZiroKun ,

Make sure to upgrade the ST-Link firmware version.

Check your power VDDA​, and make sure to select the correct Reset Mode (either by software or hardware).

If possible, please share your schematic.

When your question is answered, please close this topic by clicking "Accept as Solution".