Showing results for 
Search instead for 
Did you mean: 

ST-Link-V2 Debugger: No STM32 target found.

Associate II

Hi 🙂

Problem: STM32F030R8T6 device not found.

ErrorMsg in CubeProgrammer: "No STM32 target found! If your product embeds Debug Authentication, please perform a discovery using Debug Authentication."
ErrorMsg in CubeIde: "Error in initializing ST-LINK device. Reason: No device found on target."

Setup: I made a breakout-board for an STM32F030R8T6. The board only carries the µC and spreads out the pins to use on a breadboard. I connected all VSS and VDD pins and used 0.1µF capacitors as close as possible to the µC. I connected the ST-Link-V2 as follows:

VSS -> any GND pin

VDD -> any 3V3 pin

NRST -> NRST  (pin 7) (not sure if I need to connect the pin somehow aside from the debugger)

SWDIO -> SWDIO (pin 46) 220Ohm Pullup

SWCLK -> SWCLK (pin 49) 220Ohm Pulldown

I tried BOOT0 pin pulled low or high, both didn't work.

I double and tripple checked my connections. I am using the right pins on both sides and the µC has power.




If you are NOT using an additional power supply you have to connect VDD and VAPP (pin 1 or 2 and pin 19 on STLinkV2) to the STM32's VDD.

VDD on STLinkV2 supplies power and VAPP senses target voltage. If the programmer can't sense a voltage you cannot connect.
So here is the correct configuration:

VSS -> any GND pin

VDD -> any 3V3 pin (to supply target with power)

VAPP -> any 3V3 pin (to sense target voltage)

SWDIO -> SWDIO (pin 46) no Pullup or Pulldown, leave pin floating

SWCLK -> SWCLK (pin 49) no Pullup or Pulldown, leave pin floating

I tried BOOT0 pin pulled low to use internal storage.

Depending on you application:

NRST -> NRST tied low through 100nF capacitor


Na, it has power now :


(But it should show 3V also in the blue panel, before "connect" . Hmmm...)

So with original st-link you could try : connect nrst to st-link also,

and set reset mode : hardware reset ; (play with mode: normal, under reset...).


If you feel a post has answered your question, please click "Accept as Solution".
Associate II

You're right, I didn't catch that. I was looking at "Board: --".

I finally got it to work. I had my red wire connected to VDD (pin 19 on STLinkV2). I put it on VAPP (pin 1 on STLinkV2) and it worked. But I still have to supply 3V3. But I can just use another wire and go from STLink VDD to STM32 VDD. This way I dont have to use my lab-psu.

Thank you for your help!