cancel
Showing results for 
Search instead for 
Did you mean: 

Device is under read out protection! If you want to disable RDP please reconnect with Read Unprote

flysky
Associate II

When I was using the STM32CubeProgrammer software, I selected the USB connection development board, and directly reported the error: "Device is under read out protection! If you want to disable RDP please reconnect with Read Unprotect enabled." But the strange thing was that the other computer was normal,
Have you ever had that? That's been bothering me for a long time

Snipaste_2024-04-13_17-08-13.png

5 REPLIES 5
AScha.3
Chief

Which board ? nucleo or custom or ?

+

Did you try with "read unprotect" enabled ?

If you feel a post has answered your question, please click "Accept as Solution".
Jacob WOODRUFF
ST Employee

Hi All,

 

 

This post has been escalated to the ST Online Support Team for additional assistance. We'll contact you directly.

 

Regards,

Jake

ST Support

Read protection is not enabled

Really? Thank you very much, because our company now uses your stm32 chip

MM..1
Chief II

Try use USB2 instead USB3/C port on PC or USB2 HUB between. Too maybe chipset on your PC or drivers...

Too compare version STMProgrammer sw.