Showing results for 
Search instead for 
Did you mean: 

need ioc file for ethernet ping with udp protocol on cubemx 6.10.0 and fw 1.10

Associate III

i need a ioc file for properly pinging ethernet code with udp protocol on stm32h743 and cubemx 6.10.0 and firmware version 1.10 . thanks .....  

ST Employee


You can refer to this wiki and use the cubemx 6.10.

To give better visibility on the answered topics, please click on "Accept as Solution" on the reply which solved your issue or answered your question.

i have tried ,,,,,but still it is not pinging . can you send the ioc file directly plzz . so it will help me a lot.

Muhammed Güler
Senior III

Attached is the .ioc file of a project I made with STM32H753.
I created it with the old version, it should work if there is no migration error.

I also uploaded the original file I created with cubemx 6.4.

hello mr.guler can i get ioc files without freertos . And your code in tcp/ip but i need in udp protocol . thanks

Muhammed Güler
Senior III

I have this. You can turn off the RTOS and continue working. But managing Ethernet is much easier with RTOS.

i tried with your code ,,, but it is not pinging . and it giving some problems 

1 -->  to run the code i need to tap the run button 3 times in keil  then only code execution starting . (actually this 3 times tap for run ,,, problem i observed above 6.1.0 cubemx all versions....  )

2 --> execution stopping before  entering into the while in the main  .


so plz  check and can u explain the reason of these problems... thanks


Here are my ioc files of mx version 5.4.0 and firmware version 1.5.0 which is working fine and pinging also....  but ioc file of mx version 6.11.1 and firmware version 1.11.2 in which ethernet is not pinging and 3 tap to run issue with thiss...



Ethernet__ping.ioc generated with cubemx 5.4.0 and Firmware version 1.5.0

and another one is generated with cubemx 6.11.1 and FW 1.11.2