Showing results for 
Search instead for 
Did you mean: 

STM32CubeIDE, unable to program and debug on Windows 7

Associate III

Using STM32CubeIDE version 1.4.2 on a Windows 7 64-Bit Home Premium Edition, Version 6.1 (Build 7600) laptop, I am unable to program and debug a project on a NUCLEO-F401RE board.


When I attempt to debug to program the board and debug and run the firmware, I get an error dialog "STM32CubeProgrammer tool CLI has stopped working" and am unable to continue.


The full details from that dialog window are shown below:

Problem signature:
  Problem Event Name:	APPCRASH
  Application Name:	STM32_Programmer_CLI.exe
  Application Version:
  Application Timestamp:	5ef21602
  Fault Module Name:	STM32_Programmer_CLI.exe
  Fault Module Version:
  Fault Module Timestamp:	5ef21602
  Exception Code:	c0000005
  Exception Offset:	000cd5ce
  OS Version:	6.1.7600.
  Locale ID:	1033
  Additional Information 1:	0a9e
  Additional Information 2:	0a9e372d3b4ad19135b953a78882e789
  Additional Information 3:	0a9e
  Additional Information 4:	0a9e372d3b4ad19135b953a78882e789

When closing that error dialog I get the following error dialog from STM32CubeIDE:


Then in the STM32CubeIDE console was reported:

Encountered Error when opening 

Using a Windows CMD window, I tried to run STM32_Programmer_CLI.exe by itself and still get the same error.

Since STM32CubeProgrammer is also available as a stand-alone application, I downloaded and installed it and it works correctly with both the Windows application and CMD CLI version. However, even though its filenames are the same as the ones incorporated in the STM32CubeIDE, those files are completely different (much smaller) than the stand-alone version.

It is a show-stopper as I cannot use STM32CubeIDE on my Windows 7 machine. Has anyone else run into this problem?

As a work-around, does anyone know of a way to configure STM32CubeIDE to use the external stand-alone STM32CubeProgrammer tool instead of the internal one for downloading and debugging?

Also, I have also installed STM32CubeIDE on a Windows 10 machine and I have no problems with it there.