Showing results for 
Search instead for 
Did you mean: 

STM32CubeIDE absolutely useless for STM32CubeH7 ?

Senior II

​I've been fighting for several days with STM32CubeIDE. Right now, I just want to play with existing projects from STM32CubeH7 to learn more about the product, do some evaluations and get more familiar with the whole ecosystem.

But it turns out that using both the IDE and the MCU package is a real nightmare. There is no ready-to-use project for STL32CubeIDE so I have to import projects from SW4STM32 but the import mechanism is everything but reliable. For example it is not possible to rename the imported project : if you do so, the C files are not found anymore. Which is an issue since all projects have the name of the eval board so all projects for Nucleo have the same name. Even worse, switching from a workspace to another one breaks the project and prevents building them again. Just to compile a basic SPI project I already had to re-do the import at least 4 times. 

So frustrating and disappointing. I don't really understand the point to propose a "new" IDE if it basically cannot be used.

Bruce Ellefritz

I believe the STM32CubeIDE webpage or the documentation states that STM32CubeIDE ver. 1.0 only supports the F4 and F7 platforms as this time. Even still, my trials using the STM32F4-Discovery failed to build properly after several attempts. I feel your frustration.

​Thank you for your feedback. At least it's comforting that I'm not the only one to experience that.

More seriously I've double checked on CubeIDE webpage and I didn't see limitations regarding versions of STM32. Anyway, from IDE perspective the model of STM32 should not change a lot.

Associate II

I have the same experience with CubeMX.

I'm trying to build a simple ethernet project but after a month, it still doesn't work.

The lack of proper examples for quick start is undeniable.


Absolutely useless is an understatement !

STM32CubeIDE refuses to create H7 code for me at all. The first problem was it kept altering my clock tree even though it was legal - I was copying it from someone else on here.

So I loaded up CubeMX. This offers to create separate files for each peripheral so I asked for that but it just create the clock initialiser.

Then I went back to just writing to registers directly. I've got the thing loading code, clocking correctly and a few other things going, but there seems to be a lot of things that have to be done in a particular order to work. SAI4 absolutely refuses to come up, as does the SPI port I am using. SPDIF also doesn't work. I haven't got onto the USB port or QuadSPI yet.

STM acknowledge the H7 is a big change from the F7, so why they haven't supplied sample code is beyond me.

Associate II

I migrated a project from F7 to H7 probably a little too prematurely, and I kind of regret it now. I thought, hey, H7 is fully pin-compatible to my F7 but has enough RAM to fit two framebuffers for a LCD, so let's give it a shot. However, the integration into CubeMX is very unfortunately missing TouchGFX (which was part of the reason I chose STM in the first place). Furthermore debugging with CubeIDE does not work in my case, so I need to go back to TrueStudio.

Anyway, I guess STM employees are already working **** ** the integration of the H7 into the ecosystem, and that probably just takes a lot of time.

Associate II

I don't know if I'm experiencing the same problems, but I am trying to digitize a PID feedback loop for control of a TEC using H743ZI Nucleo board using CubeIDE. To make things worse, I am a beginner at embedded coding, and in my opinion, the STM product literature leaves a lot to be desired. They have published numerous videos trying to help us learn, but they all suffer from poor design--either no audio (text and arrows flitting around the screen) or French accented English with inadequate audio engineering that makes it almost impossible to understand. I stumbled across a user guide for the CubeIDE about a month ago, which was worthless. Now that I'm desperate, I can't find it anymore. The most recent disaster is that I spent an hour copying code from an excellent UTube video only to see it erased when I tried to compile it. UNBELIEVABLE.

Please could you share: which STM32CubeIDE version are you using ? Some data lost issue may be known but none if using latest 1.4.2 release according this forum comments.

As general comment, sounds to me helpful to community and ST guys to always share running tool release and OS reporting issue / asking for help. It is good pratice first to speedup problem solving as helping to set same context doing local trial, second to prevent to warn all of us as all not relying on same env.

Associate II

Thank you for your attention to this issue. I am using 1.4.2 with Windows 10 on a new ASUS 64bit notebook. As long as I have your attention 🙂 mostly I need help on building the code to read analog voltage at a 1kHz trigger rate from SysTick. I will then multiply that voltage by a fixed amount and deliver it to the DAC and from there back into the feedback look from the o/p of the DAC.

1) About documentation since 1.4.0 ST is providing official STM32CubeIDE user manual (see :

2) Sorry about on your analog reading case I cannot help as not so familiar with this stuff. Hoping to get some help here I would advice you to create a post dedicated to with proper title.

3) About data lost 1.4.2 issue ... too bad if confirmed. Could you share faulty workspace log traces (<workspace location>/.metadata/.log) ?

Could you confirm data lost at project compilation time (i.e. generating from sources target compliant binary)? not at code generation time (source code .c/.h files generation) ?