cancel
Showing results for 
Search instead for 
Did you mean: 

STM32CubeIDE 1.15.0: elf has a LOAD segment with RWX permissions

RajeevAroraCrcEvans
Associate III

Hi @Imen.D  , @Khouloud ZEMMELI ,

After updating the STM32CubeIDE to version 1.15.0 (today) I am observing below warning.

The LD file has not changed. It has RAM and MRAM RWX

C:/ST/STM32CubeIDE_1.15.0/STM32CubeIDE/plugins/com.st.stm32cube.ide.mcu.externaltools.gnu-tools-for-stm32.12.3.rel1.win32_1.0.100.202403111256/tools/bin/../lib/gcc/arm-none-eabi/12.3.1/../../../../arm-none-eabi/bin/ld.exe: warning: xxx.elf has a LOAD segment with RWX permissions

Memory sections in LD file:

MEMORY
{
ITCMRAM (xrw) : ORIGIN = 0x00000000, LENGTH = 64K
FLASH (rx) : ORIGIN = 0x08000000, LENGTH = 2048K
DTCMRAM (xrw) : ORIGIN = 0x20000000, LENGTH = 128K
RAM_D1 (xrw) : ORIGIN = 0x24000000, LENGTH = 512K
RAM_D2 (xrw) : ORIGIN = 0x30000000, LENGTH = 288K
RAM_D3 (xrw) : ORIGIN = 0x38000000, LENGTH = 64K
MRAM (xrw) : ORIGIN = 0x60000000, LENGTH = 1024K
}

Please help resolve the concern.

Regards,

Rajeev

42 REPLIES 42

Where is the "Miscellaneous" tab?

Thanks

PHolt.1
Senior II

Of the five places listed above I have only the last three in my LinkerScript.ld file.

But I have uninstalled Cube v15 and put it 14.1 because v15 fails to work with the debugger so is completely useless. I might try it again sometime, or just document the project as needing v14.1 (i.e. GCC tools pre-v12).

There is actually no point in constantly upgrading Cube and chasing the latest version of GCC tools. It just creates unnecessary work and if you think about it you will come to a point where you have to do that otherwise you have to allocate endless effort to a given project for ever.

Could the problem be some other part of your system, I have no problem connecting the debugger to the target and single stepping and running to breakpoints?

PHolt.1
Senior II

Multiple threads running on Cube 1.15.0 problems and I think I saw one from somebody at ST saying they agree with that "missing file" error.

There is actually no point in constantly upgrading Cube and chasing the latest version of GCC tools. 

Exactly so. There even is a rule (or lifehack) to never update to anything version X.0. Always wait at least for X.1 ))

 

Thank you,It's perfect !

davie
Associate

I change gcc toolchain from 12.3.rel1 to 11.3.rel1, that warning disappeared.

In the toolchain manager, I installed 11.3.rel1.

Hi,

I have this issue. Is there an easy fix without hacking the IDE setup files, or will ST fix this? I have no idea what to change.

Regards,

Rob

PHolt.1
Senior II

Yes; this is all because cube v1.15.0 updates the GCC tools from v11 to v12.

Normally you can expect various things to break when tools are upgraded.

Solution is to not change the tools. Revert to Cube 1.14.1.

 

Hi@robbox123 ,


@robbox123 wrote:

Is there an easy fix without hacking the IDE setup files, or will ST fix this?


you don't hack the IDE setup files by editing the linker file. You just update it to the new version.

If you generate a new project in 1.15.0 you can see the adjustments in the linker file by default.

Regards,

Jens