Showing results for 
Search instead for 
Did you mean: 

printf SWO, stlink

Associate III

Hello everyone,

I program on stm32h757 with stm32cube IDE on macOS Sonoma. (stlink v3 minie)
Until recently, I debugged with the st link and displayed printf in the swv console without any problem.
For technical reasons, I made the program work with the st link and the J trace. Since then, printf only works with the J Trace.
When I use the st link, I get an error message at start-up (see attached image)
Can anyone help me?


Capture d’écran 2024-04-08 à 17.33.37.png

ST Employee

Hello @MA4  and welcome to the community,

Could you please try the following tips to resolve this issue:

  • Ensure that the ST-LINK USB drivers are installed or reinstall from here 
  • Check that the USB cable is properly connected to the PC.
  • Download the SEGGER STLinkReflash utility from this link 
  • Start the STLinkReflash utility and restore ST-LINK
  • Agree to the license terms
  • Connect to CubeIDE and perform an ST-link firmware upgrade
  • In the debug configuration, change the debugger to ST-LINK GDB Server. Do not forget to apply and close.

Hope this helps!



Hello, thank you for your answer.

I still have the problem, same error message and the st link stops responding(Target is not responding, retrying... Shutting down... Target is not responding, retrying...)

I tried with another st link and same thing.
Is it possible that I have a problem with initialisation?

Associate III

Same error if I create a new project, if I upgrade de link, if I follow tuto only with printf

Associate III

I modified my debug configuration by checking "limit to clock" and setting 2000 kHz to max and now I get the error:

SWO trace already running on another core.

Capture d’écran 2024-04-11 à 11.59.39.png

Capture d’écran 2024-04-11 à 12.01.36.png


Any Idea ?

Associate III

after few try error comme back ...