Showing results for 
Search instead for 
Did you mean: 

Installing CUBE IDE on Ubuntu 23.04


New to STM - so far 2 major complaints...  CUBE products are basically unreadable to me...  Using a light grey on white background makes CUBE MX, at least, non-useable - can't see any themes options.

I did see that CUBE IDE supports themes so I tried to install it. - Came to grief...  Looks like it wants to use python 2.7 which was deprecated on Ubuntu quite some time ago..

I have successfully used CUBE programmer (with sun glasses on) but only succeededion bricking my bluepill when I installed the USB bootloader.  Linux does not recognize the board.  lsusb sees it.

I guess you could say I am looking for help...



Hi, I have solved the problem:
1. Install STM32CubeIDE for Linux(not for Debian).
2. Create a folder for GDBusServer by command:
mkdir /tmp/SWT-GDBusServer​
3. Compile python2 from sources, and install it like was shown here. You should only install python2, you do not need to make it primary in your system. (Optional but I don`t sure).

Also, to work correctly, you should run STM32CubeIDE from the XOrg session. Otherwise, the Cube configurator could be unavailable.


I'm using Ubuntu 23.04 and yesterday, after updating some libraries, CubeIDE stopped working. I can't run any of the versions, the program stops on the splash screen. Vitaly, did you update Ubuntu? CubeIDE is still working?