Showing results for 
Search instead for 
Did you mean: 

How to install and use gnu-tools-for-stm32 on Ubuntu 22.04 LTS



I would like to use the patched compiler from ST to build my project for STM32G4.

My goal is to setup a Docker container to be able to build the project in an CI environment on a server. 

Do you have a docker container available, where gnu-tools-for-stm32 is already installed?

I cloned the repo from Github ( and tried to run the script, but I got many errors. Is there some documentation how to install this toolchain?

Best regards,


ST Employee

Hi @FLAD ,

I got the information that the script should be run first then the

The flag --skip_steps can be used to avoid building unneeded components such as howto, etc...

Please try this way and let me know if problem is resolved or not.

If you still have errors, please share them with us.


To give better visibility on the answered topics, please click on Accept as Solution on the reply which solved your issue or answered your question.

Associate II

We try to build the toolchain 12.3.rel1 with mingw for Windows on Ubuntu. But the build process fails among others because */libiberty/pex-win32.c does not find stmicroelectronics/longpath.h. I also do not find this header? What can we do?