Showing results for 
Search instead for 
Did you mean: 

FreeRTOS RTOS Kernel Awareness not working on CubeIDE 1.8.0.

Associate II

I was previously using 1.5.1 and it was working fine, but after upgrade to 1.8.0, it's no longer working. I'm using a Segger J-Link. My Debug setting are in the picture below. This is for the device shown in the settings.


Associate II

I may have accidently found the answer. Not sure why, but disabling the SWV (Serial Wire Viewer) seems to fix the issue:


Associate II

To be honest, RTOS aware debugging breaks regularly on my system, even in between debug sessions. The way i normally work around this is to set the RTOS variant on the debug settings to something else and then start a session only to stop it right away.

After that i set it back to FreeRTOS and start a new session. This workaround seems to do the trick.

Yeah... I'm noticing that too. The solution I did above worked for a few sessions, then broke again. I will try your trick in the for future debugging sessions. Since my method was a change to the debug config, I'm starting to think that is the trigger that makes it work... some change to the debug config.

ST Employee

Hello there!

Me and one of the developers made a test with the J-Link RTOS with and without the SWV feature enabled but we were not able to see any issues.

Could you please explain what you mean by "Breaks", what exactly is it that stops working?

  1. Debugger not starting correctly?
  2. The "Debug view" does not render all the threads and/or tasks correctly?
  3. The source code is not inline with the programmed application? (which might indicate that the latest binary was not flashed properly)

Furthermore, could you try to create a new debug configuration from scratch to see if it changes the behavior in any way?

I think the post is very clear with what "breaks". The thread aware aspect of the debugger is not working correctly. Your number 2.

As explained, I've tried different configurations on several different projects. Sometimes it works and sometimes it doesn't. As stated from TBuls, if you change the debug configuration, it will work for one or more sessions, but then stops working again. So I go back and forth between enabling and disabling SWV.


A also cant get kernel aware debugging working. I have working debugging, SWV works (but is disabled). When I try enable kernel aware debugger settings, I get the message below when trying to start debugging:

0693W00000WHwcyQAD.pngUsing STM32H753, ST-Link V3, FreeRTOS. Anybody have any ideas how to get this working?