Showing results for 
Search instead for 
Did you mean: 

Can not find -l-l Error in STM32CubeIDE

Associate II

I'm using STM32-NucleoL053R8 board. I'm Getting error when I build my project I have included required libraries and its path to the project still getting error. I tried with the manual method like adding lib to the "MotionAC2_CM0P_wc32_ot.a" file added library as "${workspace_loc:/IMU_LSM9DS1_Project/Middlewares/ST/STM32_MotionGC_Library/Lib/MotionGC_CM0P_wc32_ot}" and added library path as "/IMU_LSM9DS1_Project/Middlewares/ST/STM32_MotionGC_Library/Lib"

But still getting same error. Please help me to resolve error.

Refer below Error & Path. Any help would be very thankful.




ST Employee

Hello there,

Could you take a screenshot of how the libraries are linked in the tool settings of your project? I'll attach a screenshot to show you where I mean.0693W00000LwkWwQAJ.png

Associate II

Thank you for the reply @Markus GIRDLAND,

Sure Please see the attached image. Present using only MotionFX library and included as below. Getting errors when I use MotionFX library function calls though I added include files and its path. Functions follows:


 MotionFX_setKnobs(mfxstate, &iKnobs);

 MotionFX_enable_6X(mfxstate, MFX_ENGINE_DISABLE);

 MotionFX_enable_9X(mfxstate, MFX_ENGINE_DISABLE);

MotionFX_propagate(mfxstate, &data_out, &data_raw, 0);

please help me to resolve errors.


Thank you.

Associate II


Can you please reply on above. We were unable to resolve errors as above.

Any help would be very thankful.

Hello there!

Sorry about the delay. I had a developer help me take a look at the issue so it delayed the response time a bit.

The screenshot you provided in the tool settings is looking good. Do you still have the same errors that you posted in the original screenshots despite having these settings in the tool settings? Or have you perhaps received another type of error message after doing changes to the project?

The developer had a hard time figuring out how you could receive those error message while having these setting applied, so I just wanted to make sure that the connection between the error messages shown and the settings in the new screenshots are still related?