Showing results for 
Search instead for 
Did you mean: 

STM32MP153 - How to enable HSI clock?

Dat Tran
Senior II

Hi, I set MCO1 using HSE clock and get 8MHz working well (my HSE is 8MHz)

But I need 16MHz or higher on MCO1, so I changed to MCO1 source clock by HSI but there is nothing.

I tested other CSI, HSE, ... MCO1 work, except for HSI.

I think there is something or register to enable HSI but don't know where/ what it is

Anyone know how to enable HSI clock?





ST Employee

Hi @Dat Tran 

System is booting using HSI, so unless you disabled it, it is enabled by default.

Did you try adding a divider by 4 (MCO1DIV = 3) and updating the MCO1 GPIO OSPEEDR to 0b01  ? Maybe the 64MHz is simply vanished on the output pin because too fast.


In order to give better visibility on the answered topics, please click on 'Accept as Solution' on the reply which solved your issue or answered your question.