Showing results for 
Search instead for 
Did you mean: 

Interfacing external uart peripheral with STM32MPUDK2


I have stm32mpdk2 board and trying to interface a uart based peripheral ( nfc) .I have connected Tx , RX , Vdd, GND > pin (12,8,1,6) .

tty driver is already enabled in the kernel. and the peripheral on powering up shows the init sequence correctly(led pattern is correct)

below are the logs for dmesg | grep tty*

[  0.000000] Kernel command line: root=PARTUUID=e91c4e10-16e6-4c0e-bd0e-77becf4a3582 rootwait rw console=ttySTM0,115200

[  1.702933] 4000e000.serial: ttySTM3 at MMIO 0x4000e000 (irq = 53, base_baud = 4000000) is a stm32-usart

[  1.703246] serial serial0: tty port ttySTM3 registered

[  1.704628] 40010000.serial: ttySTM0 at MMIO 0x40010000 (irq = 54, base_baud = 4000000) is a stm32-usart

[  2.915213] printk: console [ttySTM0] enabled

[  7.768477] systemd[1]: Unnecessary job for /dev/ttySTM0 was removed.

[  7.781958] systemd[1]: Created slice system-getty.slice.

[  7.817838] systemd[1]: Created slice system-serial\x2dgetty.slice.

But I cant seem to find teh correct tty for this perihperal.

Same logs comes even if I remove the device

plz advice the changes or any example for external uart perihperal interfacing


ST Employee

Some links which might help you:


In order to give better visibility on the answered topics, please click on 'Accept as Solution' on the reply which solved your issue or answered your question.


These links helped , thanks ! But Still i am not able to read from the peripheral using cat command. Cat /dev/ttySTM1 ( ttySTM1 appears only after following the instructions for USART3,thanks)

This works with raspberry pi or other linux platform on ttyS0/S1 but not on ttySTM1.

As described in the links, I read about the termios and created a non blocking read c application but still no result.

I am running built application and doing cat on the minicom-ttyACM0 ( USART1 console i guess, this should not interfere with USART3 right?)

can you please guide ,what and where to debug?

Also after this modification the GUI on the LCD doesnt go beyond the ST Banner. If I reflash the image as mentioned in the gettign started , it comes up.

GUI is important for me , as I can quickly connect,build and test my app using scp.But i need GUI to put the STM32MPU in hotspot mode.

Please respond !