Showing results for 
Search instead for 
Did you mean: 

STM32WB55 issue with BLE Connection

Associate II


Everything was working fine with my stm32wb55 until it suddenly decided to stop working. Now when I tried to upload the example firmware for ble p2pserver and connect to the web application provided by stm, i am able to connect, but the web application shows data throughput for a second and then the page reloads. I tried erasing the chip, and reuploading the wireless stack, but nothing seems to work. Any help with this would be greatly appreciated. Thank you.

Edit: i tried running the data throughput example and this is the serial output i was getting:

>>== DBGMCU_GetRevisionID= 2003

>>== DBGMCU_GetDeviceID= 495

Success: SHCI_C2_BLE_Init command

==>> Start Ble_Hci_Gap_Gatt_Init function
Success: hci_reset command
Success: aci_hal_write_config_data command - CONFIG_DATA_PUBADDR_OFFSET
Public Bluetooth Address: 00:80:e1:27:d6:6f
Success: aci_hal_write_config_data command - CONFIG_DATA_IR_OFFSET
Success: aci_hal_write_config_data command - CONFIG_DATA_ER_OFFSET
Success: aci_hal_set_tx_power_level command
Success: aci_gatt_init command
Success: aci_gap_init command
Success: hci_le_set_default_phy command
Success: aci_gap_set_io_capability command
Success: aci_gap_set_authentication_requirement command
Success: aci_gap_configure_whitelist command
==>> End Ble_Hci_Gap_Gatt_Init function

==>> SHCI_SUB_EVT_NVM_START_WRITE : NumberOfWords = 1

==>> aci_gap_set_discoverable - Success
==>> Success: Start Fast Advertising

>>== HCI_LE_CONNECTION_COMPLETE_SUBEVT_CODE - Connection handle: 0x801
- Connection established with Central: @:e0:c2:64:63:97:b3
- Connection Interval: ms
- Connection latency: 0
- Supervision Timeout: 9600 ms

**LATENCY = 0x0

set data length
change ATT MTU size
- Connection Handle: 0x801
- Reason: 0x13

==>> aci_gap_set_discoverable - Success
==>> Success: Start Fast Advertising

DTC_PROC_MTU_UPDATE complete event received



Accepted Solutions
Associate II

ok i just had to unpair the device and reconnect it. it started working again once that was done

View solution in original post

Associate II

ok i just had to unpair the device and reconnect it. it started working again once that was done


I'm currently working on BLE Client and peripheral to make a connection and communicate some sensor values. However, whenever there is a connection request made by client and a successful connection is established, immediately I see BLE_DISCONNECTION_EVT and the connection breaks.

Based on the debug message, the reason for connection failure is returning the error code as 0x3E, which translates to "Connection failed to be established". Can you help me out this?

Attaching the snapshot of the debug messages.