Showing results for 
Search instead for 
Did you mean: 

STM32WB15CC FUS error while trying to flash firmware

Associate III


I'm trying to flash \STM32Cube_FW_WB_V1.18.0\Projects\STM32WB_Copro_Wireless_Binaries\STM32WB1x\stm32wb1x_BLE_Stack_full_fw.bin at address 0x08021000 with SMTCubProgrammer version 2.14.0

I think that it is unsuccessful, and the application BL2_p2pClient failed to run.

10:24:05:288 : Reconnected !
10:24:05:288 : Success with Time elapsed during Reconnect: 1172 ms
10:24:05:288 : r ap 0 @0x20002F04 0x00000004 bytes Data 0x410FC241
10:24:05:288 : fail @0x00000001
10:24:05:288 : Warning: FUS_STATE_ERR_UNKNOWN
10:24:05:288 : r ap 0 @0x20002F04 0x00000004 bytes Data 0x410FC241
10:24:05:288 : fail @0x00000001


I have also encountered the same error  "failed to reconnect after starting FUS operator"

and I have read the post "Problem FUS when I try to load BLE Stack on STM32WB15xx" from JCALD.1
To follow instruction in "", I need a FUS file, but I did not find anything for STM32WB15CC in \STM32Cube_FW_WB_V1.18.0\Projects\STM32WB_Copro_Wireless_Binaries\STM32WB1x directory.

So, how to solve my problem? My NUCLEAO-WB15CC is out of order...

Thank you for help.
Best regards


ST Employee

Hello @FWX 

I was able to flash this .bin file to the specific indicated address on the STM32WB15 Nucleo board. I suggest you take a look at this post and follow it after performing a mass erase.

Best Regards.


To give better visibility on the answered topics, please click on Accept as Solution on the reply which solved your issue or answered your question.