Showing results for 
Search instead for 
Did you mean: 

P2P example for STM32WLE5 using Lora

Associate II


I'm a beginner and I'm trying to build a simple example which sends some data from one STM32WEL5 to anotherone using the SUBGHZ peripheral. It is supposed to work like the STM32CubeWL/Projects/NUCLEO-WL55JC/Examples/SUBGHZ/SUBGHZ_Tx_Mode example. Sadly I have not been able to get it to work yet. I used RM0461 to code the configuration of the receiver and transmitter but have not been able so receive a message.

The code is on GitHub:

All of my code is in the respectiv main.c files. I tried to make it readable and explain the code in the REEDME files.

I'm using Wio-E5 dev boards from Seeed Studios, but I don't see a reason why the RF-stuff wouldn't work on NUCLEO boards aswell. I don't have an SDR to confirm that the transmitter is doing something.

Could someone help me by reading over my configuraion and tell me, where i went wrong in the setup? If there is another example or manual, that i haven't seen yet and that could help me, that would be great aswell!



Associate II


I still am trying to get this to work. When I test the SUBGHZ_Tx_Mode Example, it works to the point where i get an answer to the 'RADIO_GET_STATUS' comand that says it's in Tx mode.
When I build my own project from the example ioc file and copy the contents of the main file from the example to the new project, it stops working. (It replies, it's in Standby mode ande there was a command execution faliure) I couldn't find any difference in any other file.

Can someone help me please? How can the same code not work in a project built on the same ioc file?

Associate II

Update: I found some code, that does something! This tutorial here:

provides code that does something. It is using the SUBGHZ_PHY middleware. I see a package beeing sent on my SDR. However: The code is written for the STM32WL55JCIx not the WLE5. A new project based on that examples ioc file doesn't compile. (Some include is missing somewhere in a utility) A new project based on the STM32WL55JCI doesn't run on the WLE5. A new project based on the WLE5 with that code compiles and runs. It reports that it is working (That is just an assumption by the middleware. It doesn't check with the radio) But the SDR sees nothing.

I'm able to get the WLE5 configured (even without the middleware. Like i did it in the example provided in the original post) and into TX mode and verify this by reading the status of the radio. (following RM0461) But stil: No package visible to my SDR.

1. How can the radio be (confirmed) in TX mode and not send anything?

On some configurationsteps, i have gotten the answer:

0x5:command execution failure (command successfully received but cannot
be executed at this time, requested operating mode cannot be entered or
requested data cannot be sent)

2. Is there a way to get more information than this?

ST Employee

Hello @Bastler 

For such a module, it will be a good idea to ask this request on our third partie's forum .

Best Regards.


To give better visibility on the answered topics, please click on Accept as Solution on the reply which solved your issue or answered your question.