Showing results for 
Search instead for 
Did you mean: 

BLE_p2pClient example does not work



I am using two NUCLEO WB15CC boards to make the BLE p2pcentral and BLE p2pServer work as said in the ReadMe of the these examples. But I always run into the same error on the client side. I am using the latest firmware on both sides. From the debug prints, server seems to work fine. Plus I can use the STM32 mobile application to control the blue LED on the server board as explained in the readme of server example. But if I press the SW1 on client side for general discovery, the attempt fails with same error BLE_App_Start_Limited_Disc_Req, Failed. Obviously, as shown below, this happens because aci_gap_start_observation_proc () fails. I replaced the original aci_gap_start_general_discovery_proc () with the observation_proc() call after going through similar posts.

But this change did not work either.



I still run into this error as below.


Can someone please help me ? I am trying to use one of these development kits to capture pakets from a particular ble beacon. I thought this example would be a good starting point. But it turns out, even the provided example does not work. Any help will be appreciated very much. Thank you !!