Showing results for 
Search instead for 
Did you mean: 

TouchGFX TextArea characters are often shown partially erased on the display

Associate III

Hi all

I am currently developing a product that uses a TFT display.  The product uses the following:

TouchGFX v4.23.2
TFT Module 320 x 240, LTDC RGB565 (16 bits), ST7272
Very often, when displaying text in a TextArea, some of the initial characters look as though they have been erased, as shown below:

TextArea erased characters.jpg

The first word should read 'SAFETY'

Sometimes, this reads correctly, eg by cycling through my screens and back to this one.

All of the other items on the screens such as images, buttons, icons etc display with no problems at all.  It's just the TextAreas that are affected. The font used is Verdana, as supplied in TouchGFX.

Any help with this would be most welcome.


Hello JTP1

I have just tried again, with 4 calls to the text area's invalidate() method in the setupscreen and unfortunately I do still see the same occasional problem.

Best regards,



Thanks for your input.  I do not use cache (yet) in my application, so this is not a solution, unfortunately.

Best regards,


Senior III

Do you see the same problem in the simulator?

Kudo posts if you have the same problem and kudo replies if the solution works.
Click "Accept as Solution" if a reply solved your problem. If no solution was posted please answer with your own.

Hello @johnhague ,

I'm very sorry for the late response, but I'm glad that you are have received plenty of help. 

Based on the new information, I'm a bit suspicious of the flash initialization since invalidation does not help in the setupScreen. Is this screen the first one that you GUI starts with?
As @unsigned_char_array suggested, if you don't see this issue in the simulation, then the problem might be because of the flash; however, if the problem also exists in the simulator, then we should investigate more.

Best regards, 


Mohammad MORADI
ST Software Developer | TouchGFX


I don't recall seeing it in the simulator.  However, I cannot get my code to build for the simulator builds in the IDE, but not TouchGFX Designer.  That's another problem though....

Hello Mohammad

Don't worry about the response being late; I'm grateful for the help.

This screen isn't the first one that is shown and the problem also sometimes happens with other screen's textareas.

I will see if I can get the simulator working. 

Not sure what you mean by it being a possible problem with flash initialisation.  Could you please elaborate, if you have time?

Best regards


Sorry for creating confusion, By the initialization of Flash, I meant verifying that the settings in the linker script for flash are correct, and ensuring that the correct data is always read from the internal flash. It might be required to adjust the bus speed for the flash. However, this is just a theory, so don't invest too much time on it if you're confident that the flash is functioning properly.

What is the error that you are facing while trying to run the simulator?

Mohammad MORADI
ST Software Developer | TouchGFX

No problem.  I think that the flash is configured correctly, as all other aspects of program operation are as expected.

The problem that I am having with the simulator appears to be path related.  In other words, it is reporting that it cannot see some files that are included in Model.hpp.  However, the project builds correct inside Cube IDE. A typical message being:

gui/include/gui/model/Model.hpp:4:10: fatal error: interface_definitions.h: No such file or directory

This file does exist and the path to it has been added to the Include path for both C and C++ builds. Also, as just stated, I do not see this when building inside the IDE.

Sorted the file include problem.  I'd inadvertently included <interface_definitions.h > rather than "interface_definitions.h".  This no longer caused that problem in the simulator build.  Am now having a similar problem, but with #include "cmsis_os2.h"....I will report back


Easiest way to run only UI in the Tgfx simulator is use #ifndef SIMULATOR and hide all .h- file includes from model and other .cpp files.