cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to program stm32h743 custom board

Luke_abc
Associate III

Hi,

I used IAR to flash the stm32h743 and I get the following error. Full log is attached (IAR_ERROR_LOG.txt)

Luke_abc_0-1699992621990.png

 

I used Jlink.exe command line to check if I can make any progress.

I tried erase command, but it did not succeed.

Luke_abc_3-1699993395330.png

 

I checked the lock bit (FLASH_CR1), it is enabled. I tried to disable it and it did not work.

Luke_abc_4-1699993531296.png

Is the MCU gone bad ?

I have another working board on which all of the above things are workings as expected.

 

 

 

 

 

4 REPLIES 4
Pavel A.
Evangelist II

While waiting for more useful replies - note that your J-Link module version in the IAR IDE is 7.88j - quite old. Consider installing the latest J-Flash version from Segger. It should find and update J-Link module in your IAR installation.

Double check capacitance on VCAP pins, and measure voltage there. Check supplies generally.

Perhaps try with BOOT0 pulled HIGH

Tips, buy me a coffee, or three.. PayPal Venmo Up vote any posts that you find helpful, it shows what's working..
Luke_abc
Associate III

Thank you @Tesla DeLorean  and @Pavel A.  for your replies.

Interestingly, running JlinkSTM32.exe solved the issue.

Luke_abc_0-1700042242865.png

Though it solved the issue, I would like to understand what can put the MCU in this state and how did this "JlinkSTM32.exe" recovered the MCU.

FBL
ST Employee

Hello @Luke_abc 

I am not sure if this is a similar thread [SOLVED] Unable to flash / erase STM32F401CC - J-Link/Flasher related - SEGGER - Forum

Same Error: Failed to restore target. RAMCode never stops
ERROR: Erase returned with error code -5.

It is related to bad board power delivery design.

 

To give better visibility on the answered topics, please click on Accept as Solution on the reply which solved your issue or answered your question.