Showing results for 
Search instead for 
Did you mean: 

STM32F405 Can not connect to target

Associate III

Hello All, I Hope you are well.

I am facing a problem that I spent A LOT of time on. I designed a custom board featuring the STM32F405RGT6 but i cannot connect to it at all.. I will attach the schematic and the board's pictures below. (The schematic is a PDF where I attached the sheet of the MCU's circuitry only there are other sheets for other parts of the board)


Things to mention:
1- I've assembled the board myself (But i checked the connectivity and voltages on the necessary nodes by a multimeter and i tested on the chip's pins not on the PCB pads and got the following:

-VDD on all VDD pins are 3.31V (measured directly on the pins)

-VDDA is also supplied by the same source with around 3.31V (measured directly on the pins)

-Vcap1 and Vcap2 are both 1.26V (measured on the the two Caps of 2u2 value)

-Reset Pin is 3.31V


2- I got suspicious about the SWD pinout that i did so i used an adapter and a Nucleo board's ST-Link to connect to my board where I measured the resistance between the SWD Pins and the Nucleo board and all are connected with reasonable resistance (Under 10 Ohms) (I got so desperate of the cause that I replaced the termination resistors of 49R9 with 0Ohms ones)

3- I got in both modes of Boot0 being Low and High. (Boot1 is floating would that cause the lack of connectivity?)


Am I missing something?!

Any kind of help would be much much appreciate. Thank you in Advance.





Accepted Solutions

Diid you check - without power - for any short to gnd or vdd or neighbor pin  ?

If you feel a post has answered your question, please click "Accept as Solution".

View solution in original post

Associate III

@Tesla DeLorean  I commented few days ago on another post and i was advised by you to post my issue separately..

any idea sir? Thanks in advance 🙏

Chief II


boot1 floating ... why ??


So you can not use bootloader, boot0 has to be low .


If you feel a post has answered your question, please click "Accept as Solution".

Thank you for your reply, 

I've soldered a wire and i pulled boot1 low through a 10k resistor.. and then tried to pull it high .. but with the same result.. would this mean that my chip is dead? 

Would it be dead even if i see the reset pin voltage as expected and both vcaps1&2 showing proper voltage? What do you think is the issue here?

Seems everything ok (if boot0 lo ! ) , should work.

Maybe you puzzeled the swd pins ? (mirrored pinout .... i have workmate, that "loves" to do this. But always 100% sure, he did right. )

Try connection with CubeProgrammer ... best, to see, whats going on.

Show, what it tells or shows.

If you feel a post has answered your question, please click "Accept as Solution".

I did miss up the swd pins.. however i connected the wires one by one (out from the adapter) to the st-link section of a Nucleo board (I tested this to identify a bluepill board which it did successfully).. and i tested with a continuity test from every single pin to the swd header on the Nucleo board


then i tried with my custom board but it didn't work.. it's very frustrating 

>I did miss up the swd pins


>then i tried with my custom board but it didn't work.

So you still have a very basic / *** error there.

What shows CubeProgrammer with your board ? ( show screenshot.)


If you feel a post has answered your question, please click "Accept as Solution".

Regarding the CubeProgammer, I'm sorry but i can't seem to find a place to download this anymore! Any ways I attached screenshots from st-link utility, and from the CubeIDE, as well as the application note and connections i used to recruit my Nucleo board's st-link as a programmer (which i tested successfully for a BluePill board (an stm32F103)).


I tested again the voltages and got the following:

VDD on all 4 digital supply pins is 3.35V

VDDA is 3.35V

NRST is 3.35V

Vcap1 is 1.26V

Vcap2 is 1.26V

Boot0 is 0V

Boot1 is 0V


CubeIDE Message No target found.png

st utility message no target found.png

The Guide I followed to use the Nucleo's st-link as a programmer.jpg


So, st-link utility is old and deprecated. Not useful - dont use it.


CubeProgammer you must get. Where are you ?  (Maybe VPN (from Germany or France) could help, if yor country is on some blacklist . 🙂  (not my business..))


Message in IDE  helps nothing - just it cannot "see" any target. (Always same message - if not working.)


You connected also VDD 3v3 to st-link ? It checking the voltage, if too low, it dont work.

If you feel a post has answered your question, please click "Accept as Solution".

Thank you, i didn't know there was some kind of a blacklist in the first place,, anyways I'll try to get the CubeProgrammer and get back if i had any useful updates. Thanks again for your time.