cancel
Showing results for 
Search instead for 
Did you mean: 

STM32F072 DFU not working (incorrect serial number read)

RMoli.3
Associate III

I have a custom board that I need update by USB. I have a jumper that allows setting the following:

  • nboot bit set to 1
  • BOOT_0 pin set to 1.

Then I power on the board and I can see the stm32 bootloader device on my windows machine. 

First I get a similar behaviour as https://community.st.com/t5/stm32cubeprogrammer-mcus/problem-with-dfu-and-stm32f072b-discovery-board-cubeprogrammer/td-p/254296 . However, after accepting the disable request from the STMCUbeProgrammer (even though it was never enabled) i get the error (Device is under Read Out Protection)

RMoli3_0-1699539991629.png

The device is not in read out protection. I have not enabled or modified any option bytes and the device has had all its flash erased before the procedure. I can see that it is not correctly recognizing the Target information (Board, device, type, etc).

My schematic is as follows (I have tried with and without R31)

  • USB_DM = PA_11
  • USB_DP = PA_12

RMoli3_1-1699540288281.png

Any ideas what may be causing this behaviour?

 

 

 

4 REPLIES 4
STOne-32
ST Employee

Dear @RMoli.3 ,

 

try to remove the R31 resistor - pull up / power off and on again and check if the same behavior ? 

Cheers,

STOne-32 

STM32F0672 ?? What part?

There are some F0 series parts that don't have a Unique ID burned in them.

Tips, buy me a coffee, or three.. PayPal Venmo Up vote any posts that you find helpful, it shows what's working..

Dear @STOne-32 I have tried with and witout the R31 pull up and the behaviour is the same

Dear @Tesla DeLorean the device I am using is STM32F072CBT6 

As far as I am concerned from AN2606 does have a DFU bootloader if HSE is enabled