cancel
Showing results for 
Search instead for 
Did you mean: 

Revert .ioc file for older CubeIde version

SSorr.1
Associate II

Hello,

I recently upgraded to CubeIde 1.6.0 but I am having many new problems when programming STM32h/43: the configurations generation is much slower and it often stops updating all needed files, which forces me to reboot (I could not find a better way).

So I decided to downgrade to 1.5.1 which was stable for me, but I cannot load the .ioc files that were generated with 1.6.0. Is there a workaround?

1 ACCEPTED SOLUTION

Accepted Solutions
CCend.2
Associate III

Open the IOC file in a text editor and change the line "MxCube.Version=***" to the version of CubeMX that your version of the IDE wants you to have.

View solution in original post

4 REPLIES 4

>>Is there a workaround?

I'm sensing there isn't, I guess you could try a text editor or a merge tool to understand the change in features/structure.

Importing older .IOC has been a challenge at times, I'd definitely recommend doing this into a sandbox project rather than a live one, as file loss has been reported on multiple occasions.

Tips, buy me a coffee, or three.. PayPal Venmo Up vote any posts that you find helpful, it shows what's working..
CCend.2
Associate III

Open the IOC file in a text editor and change the line "MxCube.Version=***" to the version of CubeMX that your version of the IDE wants you to have.

wow, it really works for opening the 6.3.0 version ioc file by cubemx 6.2.0, thanks bro

Yes it work but MxCube.Version=**** we need to set  MxDb.Version=**** acordinglly.

Thankyou so much your advice is very helpful.