Showing results for 
Search instead for 
Did you mean: 

LL_RCC_LSE_IsReady loop forever


The issue is gone, but I couldnt understand the source of issue. After a day programming a dev board with stm32h750, almost all peripherals works correctly. However, suddenly the LL_RCC_LSE_IsReady keep return 0 forever. I tried to reload the code, and even modify, but LL_RCC_LSE_IsReady kept loop forever. I have a super cap connected to vbat, so in order to perform a full reset with rtc backup, I made a short circuit in terminals of supercap. After a while, when cap voltage down to 600mv, i turn on again, and debug, and the issue with LL_RCC_LSE_IsReady was solved, now is returning 1. Any clues? Do you think, this could happen again?

ST Employee

Hello @Community member​ 

I not sure about all the details, but i suspect that the RTC locked-up the LSE and you couldn't restart it.

As you said "perform a full reset with rtc backup" solved it, so there is a way to do it by software by doing a backup domain reset (by setting BDRST bit)

Hope it helps



To give better visibility on the answered topics, please click on Accept as Solution on the reply which solved your issue or answered your question.