Showing results for 
Search instead for 
Did you mean: 

Hi All STM32 users, has anyone successfully done any debugging using VSCode with all the relevant packages installed along with the ST-LINK/V2 probe on Linux?


I have all the relevant ARM utils/etc on the system.

As soon as I try to run, I get this message-

"Could not start GDB process, does the program exist in filesystem?"

Tried jumping through hoops for last few days but getting no where.

Tried with all kinds of variations to the Launch.json but no joy.

Anyone know a way forward?

Processor is STM32F746



Imen Ezzine
ST Employee


Thank you for sharing your feedbacks!

A quick look on the description seems to be linked to CubeIDE. I can say you either don't have the CubeIDE software installed or that it is perhaps not properly installed that it can't be found by the Microsoft scripts. For now Vscode requires to have STM32CubeIDE installed in the default location for your platform. This has been tested with 1.9.0 version of the CubeIDE.

Let me know if this could be the issue.

Kind regards,



Thanks for coming back on this Imen.

And sorry for late response, been away for a while.

Although I did have CubeIDE on the system, as I said in the question I am running on Ubuntu Linux 18.04LTS version to be specific, using Vscode and Cortex-Debug extension.

I have since obtained a Segger Jlink probe and although I can launch a debug session now in VSCode and stop at a break point to examine some variables, it is not running properly.

I cannot for example get any printf's to work at all for some reason. Plainly I am doing something wrong.

My application uses FreeRtos taking care of various tasks.

And although it stops at a breakpoint it seems the processor just carries on after displaying a few watches I have set up.

I removed CubeIDE incase this could be causing any issues, but obviously not.

Any thoughts on this Imen

Thanks again


Associate II

@WTAYL.1​ I have the basic setup on Zorin OS 16.1 (Ubuntu 20.04 LTS) and Cortex-Debug seems to work just fine with VSCode. It also works with FreeRTOS.

I am afraid I am not able to post a link in here. But if you go to YouTube, you can use these keywords to search for the step-by-step guide: `step-by-step stm32 eka susilo`

Hopefully it helps you to solve your problem. Thank you.