Showing results for 
Search instead for 
Did you mean: 

Flash memory problem in STM32H755ZI

Associate II

Hello everyone, I am having a small project as follows: When I press a button the program jumps to a new program which is located in a new address space. I have successfully tried with STM32F4 series but when switching to STM32H755ZI series which is dual-core series, the project does not work properly. Can someone help me. Thank you very much.

ST Employee


1) Have you tried to set a breakpoint to see what is happening ?

2) you could show a bit of your code to increase the chances that someone helps you.

Hello, I tried following your advice but it didn't work so I took some code that I wrote hope you can help.

0693W00000UnQUoQAN.pngThis figure is the code in my first program, when I press the button it jumps to the address 0x08020000.0693W00000UnQUyQAN.pngThis figure is my new application program, in the new program I have edited the Flash memory start address to be 0x08020000 and now the size is only 256KB.0693W00000UnQV8QAN.pngThis picture is also the application program like the 2nd picture, here I have edited VECT_TAB_OFFSET to 0x00020000 to match my new address 0x08020000.

If you notice anything let me know, thanks a lot.