Showing results for 
Search instead for 
Did you mean: 

Problems with the X-NUCLEO-IHM07M1

Associate II

Hello everybody,

I have a Problem with the X-NUCLEO-IHM07M1 power board . I am using it with the Nucleo-F401RE.

My setup :

Software: Cube IDE + ST Motor control workbench 5.4.8 (I have also tried it with V. 6.2.0)

Motor: Maxon EC i 30 , Art. No 539477 (24V , 2 pole pairs, Hall Sensors)

With the power board X-NUCLEO-IHM08M1 it works . Same setup and software. 

For me it is a little bit confusing because X-NUCLEO-IHM08M1 power board is for bigger motors than the Maxon Motor and in my opinion it should work better with the X-NUCLEO-IHM07M1.

If anyone has any ideas about this problem or needs further informations, please let me know.

Here is a screenshot from the motor data sheet.

Screenshot 2024-04-17 174010.png

Parameters workbench:

Parameters maxon.png

ST Employee


What kind of issue are you facing with X-NUCLEO-IHM07M1?
You mentioned "Same setup and software"; as IHM07 and IHM08 are differents, you should re-generate a project for each power board.

If you agree with the answer, please accept it by clicking on 'Accept as solution'.
Best regards.

Hello @GMA ,

I meant with same software , the same programs(Workbench, motor profiler, cube ide) and same versions of them.

I have two different projects. One for each power board. When using the IHM08 power board, I observed short peaks in the input current, reaching up to 3.5 A(You can see it in the picture below). I have also a voltage drop at the DIA/EN Input of the IC L6230PD, which is used for the board IHM07. 

But this signal is never used in the code for the board.

Voltage drop of the DIA/EN Signal measured at PIN CN10/13



Input current for the motor. 100mV = 1 A(Board IHM 07)


Input current for the motor. 100mV = 1 A(Board IHM 08)


I have tried it with and without Hall Sensors,different PWM Frequency ( 5000-25kHz), but nothing works.

If you have any ideas or you need further informations, please let me know.

Thank you for your help.


best regards 



My question about "issue" was more, with IHM07, do you have a reported error? Does the motor spins?

If you agree with the answer, please accept it by clicking on 'Accept as solution'.
Best regards.

I got no reported error and the motor does not spin. The motor just makes half of n cycle and stops there. 

I got no error and nothing happens after this short movement.

Hello @GMA ,

n addition, I have noticed that the STM workbench shows me a speed on its monitor, but the motor does not move. I had the same problem with the Motor Profiler.

After checking several times, everything is wired correctly. The jumpers are also set correctly.

I also noticed that there is an error when generating code because I am not using Oracle Java8. Could this be related? However, it must also be said that I get this error every time and the motor still turns with the power board "ihm 08, so I thought it could be a software bug.






I am able to have such behavior if U and W phases are inverted, did you check Motor phases and Hall sensor connections with IHM07?
Did you try the 5.4.8 motor profiler (with F401+IHM07) to check if motor spins in this case?


If you agree with the answer, please accept it by clicking on 'Accept as solution'.
Best regards.

Hello @GMA ,

I have checked the wiring several times and I also tried it with the power board IHM 08 and with this board the motor spins(same wiring). So I think the wiring is correct. 

I have also used the motor profiler and the motor does not spin . 

Could the L6230PD be the problem, because the peak of the output current is too high.

Maybe I just need another Motor, which is a little bit smaller.