Showing results for 
Search instead for 
Did you mean: 

HALL sensor Pin out only 3.3v

Associate II

Hello guys

I'm trying to do a profiler for Hall sensors.
But when I measured my Hall power pins they only provide 3.3V instead of 5.0V and my Hall sensor needs at least 4.5V, I tried to check my control board manual and found that my SW is in the right direction but it only provides 3.3V, I tried to turn it off with CUBE MX (Save power of non-active UCPD - deactive Dead Battery pull-up). deactive Dead Battery pull-up) but it doesn't turn it off. Please provide me some suggestions.

My control board with the power supply version is



ST Employee

Hello @poyilee,

On IPM20B board, could check that jumper SW16 is on position 1-2?

The 5V comes from G474RE board, could you check the 5V source on IT?
On NUCLEO-G474RE, JP5 is used to select the 5V source.

If you agree with the answer, please accept it by clicking on 'Accept as solution'.
Best regards.


These photos are an experiment I tried, I tried connecting jp5 to 5V_Vin using a 7v supply voltage, still the same problem.
As shown in the picture, during the test today, I found that the voltage returned to 0 directly after connecting the hall board. This hall version is normal. I tried other hall versions and the same thing happened.
I have connected SW9 and SW16 correctly.
The software version I am currently using is: MCSDK 6.2.1/CUBE IDE 1.15.1/Motor pilot 1.2.5

Hello @poyilee,

Using 5V_STLK, could you disconnect your Hall Sensor and check that 5V is present?

On the other hand, could please separately check the current consumption of your Hall Sensor connecting it directly it to your DC Power Supply?
USB 2.0 standard ports can provide up to 500 mA.

If you agree with the answer, please accept it by clicking on 'Accept as solution'.
Best regards.

When I disconnect the hall sensor the max voltage is only 4.2V, I tried to use a 3.3V hall but he doesn't respond.
I use an external power supply to supply the hall sensor with no more than 300ma max.
Is it a software problem?
I am using
cube ide 1.15.1
MC workbench 6.3.0