Showing results for 
Search instead for 
Did you mean: 

6Steps_STEVAL-SPIN3204 - Impossible to update or generate project


Dear Community,

In order to test the STEVAL-SPIN3204 kit, I installed the software environment as below:

  • Latest Java updated
  • Latest Keil MDK-ARM
  • Latest IAR EWARM
  • Latest STM32CubeMX
  • Latest ST Motor Control SDK 5.4.7
  • Firmware Package Version STM32 FW V1.11.3 and recommended STM32 FW V1.11.2

I tried anything any combinaison but the problem remains: when I click to "Update" the project "6Steps_STEVAL-SPIN3204" through the "Project generation" screen as recommended, nothing happens after a long time and nothing is generated; I have to click "Cancel" to exit.

Can you give me your opinion if something can be wrong in my procedure or your instructions please? I am sure that it is just a little thing blocking...

(on the picture, the Firmware Package Version is now installed but the result is the same)

Thank you in advance.

Best Regards,


Ronny Landsverk
Associate III

Did you solve the issue ? I have the same problem...

Other uses says to downgrade CubeMX (see link).

Ronny Landsverk
Associate III

Just downgraded to CubeMX v6.3.0 and now it works