Showing results for 
Search instead for 
Did you mean: 

STM32F407 discovery board: USB and I2C issue

Associate II

Is there anyone who experience this issue?


I use eeprom with I2C and USB OTG communication in STM32F407 discovery board. There is no common GPIO pin.


whenever I use USB OTG to write something in eeprom through I2C, USB and I2C looks disabled in same time. 


I googled it and found there are similar issue but no solution at all.


is there any solution?

Andrew Neil
Evangelist III

@Jimmy_LEE wrote:

USB and I2C looks disabled in same time. 

What do you mean by that?

What investigation/debugging have you done to find out what's going on ?

Muhammed Güler
Senior III

Are you sure there is no problem with interrupt management?
I felt that you were trying to perform long operations within the interrupt without seeing your code.

ST Employee

Hi @Jimmy_LEE 

Would you provide a minimum example to replicate this issue? you can check if it's applicable on specific I2C / OTG instance?

To give better visibility on the answered topics, please click on Accept as Solution on the reply which solved your issue or answered your question.

literally looks all function stop. No usb communication response to PC and no I2C response.


I have debugged them but I have no idea about this issue...

I think there is no problem with interrupt management. This is really weird. I have checked I2C interrupt couple of times..



You've marked this as solved - but it doesn't seem to be?

See this to un-mark a solution: