Showing results for 
Search instead for 
Did you mean: 

HAL_GetTick always returns 0 for STM32G431CBT6


I've been trying to use the Hal_Delay function and found it not working. Looking into it, it appears that the sysTick interrupt is not going off to increment the count. Any ideas what is causing this? Is it possible that the interrupt vector is set up wrong? I've tried making sure that interrupts are enabled and that systick is set on highest priority, still nothing. Any help is appreciated


Interrupts are probably turned off and/or you're in a higher/same priority interrupt.

If you feel a post has answered your question, please click "Accept as Solution".
ST Employee

Hello @DAgui.3,

Could you share your SW setup? IOC file ? 

It is possible that the timeout has increased in your application. Could you share a minimum project to reproduce the issue?

@Pavel A. unfortunately your post was mistakenly misplaced.


To give better visibility on the answered topics, please click on Accept as Solution on the reply which solved your issue or answered your question.