Showing results for 
Search instead for 
Did you mean: 

Can't start nsh of nuttx on STM32F429IDisco

Iqbal Hossain
Associate II
Posted on August 16, 2017 at 13:57

I am trying to run nuttx on STM32F429IDisco device. I am following tutorial from nuttx official channel on youtube. Few days ago i was not able to start minicom. But after some study i was able to start it, using /dev/stlinkv2_2.


Anyway, at this moment i am stuck at very next step. My minicom have succesfully started but i can't start nsh to run my programs by clicking reset button. 

Can anybody tell me what is the wrong i have done ? stlinkv2_2 isn't right way to setup device? or any other mistake? 

My development Environment: Ubuntu 16.04

#nuttx #usb #nsh #stm32f429disco
Posted on August 16, 2017 at 14:46

I think there are not so many Nuttx users in this Community. You may expect better support in the Nuttx

than here.


Ha! Who could've guessed that Gregory Nutt himself is here..

Gregory Nutt
Associate II
Posted on August 16, 2017 at 16:03

There is a verified usbnsh configuration in nuttx/configs/stm32f429i-disco/usbnsh.  Are you using that?

Posted on August 16, 2017 at 16:59

No! I am using stm32f429i-disco/nsh

Posted on August 16, 2017 at 18:42

That configuration does not support the USB serial console interface.  If you want the USB console, you need to use the usbnsh configuration.  That is the difference between the two configurations!

Posted on August 16, 2017 at 18:47

Savoir-Faire is everywhere!

Posted on August 16, 2017 at 19:03

Thanks ....I will let you know after testing

Posted on August 16, 2017 at 22:04

Deja vu gets repetitive after a while...

Tips, Buy me a coffee, or three.. PayPal Venmo
Up vote any posts that you find helpful, it shows what's working..
Posted on August 17, 2017 at 08:03

I have tried with

stm32f429i-disco/usbnsh but no luck!

still the nsh console is not starting....reset button clicking doesn't start the nsh console.



I have configured Serial Device /dev/stlinkv2_1 ... before that i tried tty0, ttyUSB0, ttyACM0, ttyS0.

I got not found errror for USB0, ACM0. tty0 and ttyS0 shows no error.


When i configured


at least the device responses. I mean if i unplug the usb at least it shows warning..


What should i do now ?


Posted on August 29, 2017 at 08:32


‌ Please look at the issue