Showing results for 
Search instead for 
Did you mean: 

Updated STM32CubeIDE from 1.14.1 to 1.15.0 and now projects no longer can be launched.

Associate III

Been running STMCUBEIDE 1.14.1 for a long time. Installed 1.15.0 and got  the failed to load MI error.

Am using Windows 10, a custom board with a LSM32L476 chip, linked with a STM32 LINK V2.

I can still load and run the NUCLEO board over the USB connection. It has a built in link. 

Uninstalled 1.15.0 and reinstaled 1.14.1 and it got same "FAILED MI COMMAND"error. Reinstalled 1.15.0. STMCubePGM now also got same error. Tried STMCube IDE and got same error.

Started fresh using STM32CubeMX and created a new simple project and got the same IDE error.

Need to know how to get around the following launch error:

Launching Larrry 9 Debug has encountered a problem

Error in final launch wequence.

Faled to execute MI command:

target remote local host61234: connection timed out.

Error in final launch swequence.

Failed to execute MI command

target remote localhost: 61234

/errir nessage frin debygger back end:

local host:61234:connection timed out,

Failed to execute MI command

Error messaage from debugger back end:

localhost:61234:aconnection timed out.