Showing results for 
Search instead for 
Did you mean: 

"ST-Link not detected" error message popping up and STM32 not detected on device drivers


So I've just gotten into the world of bare metal programming. Currently using a STM32F407G-DISC1 board on Windows 11 2H22. I was trying to run a toggle LED code on it. the code built without a hitch, but upon debugging in threw up a "No ST-Link detected error" message. I've spent the last 2 days trying to fix this issue but have no luck yet.

Here's what i've tried:

- completely uninstalled and re-installed stm32cubeide

- installed en.stsw-link009 drivers for st-link, and even though they downloaded successfully I am unable to see my device in the device manager.

- tried on both windows and mac and have the same issue. ("No ST Link Detected")


My board is working fine as the startup sequence is how its in the datasheet. 

--> PWR LED ON, LD3,4,5,6 lighting up in sequence, and COM LED Blinking.

ST-Link Pins (CN3) and JP3 pin are both also bridged on the board.


Please let me know what could be the issue. Is it windows 11? Any drivers I'm missing. Will list out my system specs below:

- OS: Windows 11 2H22

- Board: STM32F407G-DISC1

- STM32CubeIDE Version - 1.12.1 (have done fresh install).