Showing results for 
Search instead for 
Did you mean: 

problems with ST-LINK/V2 drivers

Associate II
Posted on May 11, 2011 at 19:44

Hi all,

I'm experiencing connection problems when using the STM32L-DISCOVERY kit with the ST-LINK Utility software v2.0. I supose this is a matter of drivers but I'm not 100%sure. Is there anybody facing the same problems?



Associate II
Posted on May 18, 2011 at 08:39

Hi Joan

 Sorry for the delay.

 You need to install ST-LINK/V2 driver after installing EWARM 6.20.

What's kind of problems have you detected? Error message, symptoms, ..




Associate II
Posted on May 20, 2011 at 13:51

Hi Phil,

The probelm comes when using the Atollic IDE to program the boards. It seems that something is corrupted during the comunication and I'm not able to conect to the board anymore ( even with IAR, ir STVP tool ).

Right now I'm using IAR without any problems.

Did anyone tried to work with atollic with the STM32L-DISCOVERY kit?



Associate II
Posted on May 23, 2011 at 09:30


It seems that I have the same problem. I installed TruStudio Lite, debugged a sample application successfully couple of times, then it suddenly stopped working and TruStudio can't connect to the discovery board again.

Quite unusual as ST-LinkUpgade.exe can still connect ok and upgrade the ST-Link firmware.

STM32 ST-Link Utility wasn't working with the discovery board at all. It seems that the ST-Link firmware loaded on STM32L-Discovery is not compatible with the current version of ST-Link Utility.

It's good to see that the basic UART bootloader for uploading firmware and the ARM GCC can be used successfully on the STM32L-Discovery board (just had to change the boot0 and boot1 settings).


Posted on May 28, 2011 at 03:44

I have a similar problem when using the STM32L-DISCOVERY kit with the ST-LINK Utility software v2.0.

1. The ST-Link Utility v2.0 does not recognize that the STM32L-DISCOVERY is plugged in. 

I get the error messages, ''No STLink detected'' and ''Cannot connect to ST-Link''.

2. The ''STMicro ST-Link Firmware Upgrade 1.12.3'' program detects the STM32L-DISCOVERY and reports ''Firmware Version V2.J14.S0 JTAG Debugger''.

It updated the firmware successfully when I pressed the ''Yes>>>'' button.

3. The firmware updater built into ST-Link Utility v2.0does not recognize the  STM32L-DISCOVERY board and reports ''ST-LINK is nonexistent. Please connect it and then retry.''

4. Atollic Truestudio connects to the STM32L-DISCOVERY board and I can download and run various programs without a problem.

My Conclusion: ST-LINK Utility v2.0 has not be updated yet to work with the  STM32L-DISCOVERY board.

Two other pieces of software are able to recognize the board and download code just fine.

Posted on June 08, 2011 at 18:16

I found out from our ST contact that there is another ST program that can be used to program the STM32L-Discovery board.

The ST Visual Programmer has support for JTAG and SWD and it works to program the the STM32L-Discovery board.  It accepts a HEX or S-record output file from your compiler. 

I started using the Atollic IDE which supports this board directly.  When I switched to Rowley Crossworks 2.0 I found that Crossworks supports the ST-Link JTAG interface, but not the SWD programmer built into the STM32L-Discovery board.

With the ST Visual Programmer I was able to program a HEX file from Crossworks into the STM32L-Discovery board.


The ST Toolset (which includes the ST Visual Programmer) can be downloaded from:

Associate II
Posted on June 16, 2011 at 16:49

I might be able to adapt the versaloon firmware for the STM32L-Discovery board (Jtag part), as i did for the STM32VL-Discovery & STM8S-Discovery.

Then you can use Win/Linux/OSX and OpenOCD to debug/program.

If someone would donate a board or two (ST .. Hint...Hint)

Btw: ST .. Nice board


Associate II
Posted on June 17, 2011 at 12:30

I have a similar problem. I purchased ST-LINK/V2, but it does not operate with ST-LINK Utility. Same error message - ''No STLink detected''. Did you find a solution?

ST Employee
Posted on June 17, 2011 at 15:30

ST-Utility 2.0 doesn't support ST-LINK/v2 yet. You can use STVP instead. If you really need ST-Utility here is some quick and dirty solution ... no warranty ... if you will follow you are doing it at your own risk.

1. Find path where is installed ST-Link utility e.g. ''C:\Program Files\STMicroelectronics\STM32 ST-LINK Utility\ST-LINK Utility\''

2. Make backup of file ''STLinkUSBDriver.dll''.  You can rename it to ''STLinkUSBDriver_backup.dll''

3. Download and install latest STVP.

4. Find path of STVP. Something like ''C:\Program Files\STMicroelectronics\st_toolset\stvp\'' and copy file ''STLinkUSBDriver.dll'' to the installation folder of ST-LINK Utility.

5. That's it. You should be able to communicate with ST-LINK/v2 by using ST-LINK Utility.

Happy debugging

Posted on June 20, 2011 at 07:18

I'm having no luck with either the ST-Link Utility, nor the ST Visual Programmer.

After installing the ST-LINK/V2 USB drivers, which Windows XP seemed to accept, both programs think there's nothing connected.

Using the Resource Selector on the ST website, when selecting Software Resources | Tool | Device Programmer, the ST-Link is clearly shown as being for the STM32L1xx series, so that's very misleading if in fact, it is known not to work.

Trying STVP, I went to the configuration dialog box, selected ST-LINK in the hardware column, and STM32L152xB for the device. Neither selecting JTAG nor SWD made any difference. When trying to ''Read current tab'', it says initially ''unknown mcu target'', but all attempts after that get ''Cannot communicate with the tool. Wrong tool selection or check your connections.''

I don't need to play with BOOT0/BOOT1 when using the ST-Link, do I?

My jumpers are set to Discovery and not ST-Link, which is just for the passthrough mode, to program off-board devices, isn't it?

I assume my device is okay, as I can talk to it using the bootloader via UART1, using the open source stm32flash tool (though I had to add in the definitions for this chip- the whole of the web seems to think this board doesn't exist!). I can't yet flash via this tool, but it at least gets a response to the question of ''what mcu type are you''.