Showing results for 
Search instead for 
Did you mean: 

Hello everyone, I'm having a problem with my 2 of STM32H745I-DISCO boards. Code could not come to main while(1).

Associate II

I saw the problem when I use them for a basic LED Blink code. The Code got stuck in a while loop in SystemClock_Config() function. I tried lots of things.

My __HAL_PWR_VOLTAGESCALING_CONFIG(PWR_REGULATOR_VOLTAGE_SCALE1) will not return to SystemClock_Config(). I found that PWR->CSR1:ACTVOSRDY bit is staying at 0. I could not find any solution.

In my hardware the power supply was SMPS supply as its default. I did not change anything on hardware.

The same error occurred even if I use the example codes from CubeIDE. This time, the code got stuck in a similar structure but in SystemClock_Config() also here.

More interestingly, both my 2 of the STM32H745I-DISCO boards have the same problem.

How can I fix the problem, I am open to any suggestions.


Hello @Furkan Yüksel​ ,

You can refer to the following example provided under the H7 Firmware Package:

  • Path: Firmware\Projects\STM32H745I-DISCO\Examples\GPIO\GPIO_EXTI

Otherwise, make sure you are not in the simulator debugger mode and take a look at this video, it could help you.

BeST Regards,


Associate II

The problem in GPIO_EXTI in my board is that in the line 138 in main.c (for CM7) the code has


The code got stuck in here, similar to my other projects either that I created or the examples that I used. They are all got stuck in the SystemClock_Config(), the stuck point changes only

Anything remarkable about how these boards are powered?

Modified, got other shield / boards plugged in?

Shouldn't have an LDO / SMPS issue as the code specifically targets the board.

Tips, Buy me a coffee, or three.. PayPal Venmo
Up vote any posts that you find helpful, it shows what's working..

I use CN3 -> VIN to power the board. I did necessary manipulations to properly power the board.(JP8 -> E5V jumper is used)

On the board the LD4 LED is indicating whole board powered or not. I do a double-check on it.

However, although I tried the other power selections like powering on STLink's USB, the behavior did not changed.

I use only the board. I did not modify it. Therefore the board is in default state (SMPS). I double-checked it by looking the components that are placed in the board and not placed in the board. I am sure that board was configured as SMPS.

Therefore, I don't think that the problem is a LDO/SMPS issue. There could be problems in the SPMS configuration components, but my second board has the same behavior which makes me confused.