Showing results for 
Search instead for 
Did you mean: 

Error: No STM32 target found!

Associate II


i am using STM32H735G-DK. everything was good i programmed the board more times and it was working fine. but now I have no idea what happened with my board. i tried to upload firmware using stm32 programmer but problem is as it is.

 15:10:51 : STM32CubeProgrammer API v2.12.0 | Windows-64Bits 

 15:11:33 : ST-LINK SN : 001F00303438510734313939

 15:11:33 : ST-LINK FW : V3J10M3

 15:11:33 : Board    : STM32H735G-DK

 15:11:33 : Voltage   : 0.12V

 15:11:33 : No STM32 target found!

 15:11:33 : ST-LINK SN : 001F00303438510734313939

 15:11:33 : ST-LINK FW : V3J10M3

 15:11:33 : Board    : STM32H735G-DK

 15:11:33 : Voltage   : 0.10V

 15:11:33 : Error: No STM32 target found!

Please anybody let me know if you have any suggestion to solve the issue. i have already tried below solution mentioned in STM32H735G-DK manual still problem not resolved.

If a deadlock occurs because of a mismatch between hardware and firmware PWR settings (SMPS/LDO), the user can recover the board by applying the following procedure:

1. Power off the board.

2. Set SW1 (BOOT0) to 1 (system memory). This changes the BOOT0 pin to 1 instead of 0, thus changing the device boot address to boot address 1 and making the bootloader start in System memory. This avoids starting firmware in the user Flash with a wrong SMPS/LDO configuration versus the hardware board configuration.

3. Power on the board and connect using STM32CubeProgrammer (STM32CubeProg). 4. Erase the user Flash.

5. Power off the board and set SW1 to 0.

6. The board is recovered and can be used normally with matching firmware PWR.


No voltage on the Target​ seems problematic. Is there a current jumper missing, or some other issue with the power. I'd perhaps double check with a scope or multimeter.

Tips, Buy me a coffee, or three.. PayPal Venmo
Up vote any posts that you find helpful, it shows what's working..

thank you for prompt reply.

  1. current jumber is connected. and i have checked current consuption by removing JP1 and keep multimeter across it is 60 miliamp. i have connected board using ST link.0693W00000WLJGNQA5.jpg0693W00000WLJGDQA5.jpg

Check the vdd sensed line stlink.

Check the boot pin

Check if the oscillator is working

Use STLink and try to go debug mode


Hello @Dharmesh​,

I recommend you checking the How to unbrick an STM32H7 after setting the wrong power mode article.




I followed to connect board under power down mode but still getting same issue No STM32 target found!.

here i have attached image for your ref.0693W00000Y7HCOQA3.jpg

And one more LED LD3 continue ON..

This LED is for STLINK-V3E Over Current.