cancel
Showing results for 
Search instead for 
Did you mean: 

Cannot flash NUCLEO-L432KC with modified solder bridges

yaak_d3v
Associate

Hi,

I need to test power consumption on NUCLEO-L432KC with UART working on high baud rate. I've removed SB9 and SB14 to do so. Board is powered by external 5V source. While trying to flash following the Chapter 6.4.2 (External power supply inputs) from User Manual I get: 

 

 

  13:19:51:737 : UR connection mode is defined with the HWrst reset mode
  13:19:56:786 : ST-LINK SN  : 012345678910111213141516
  13:19:56:786 : ST-LINK FW  : V2J31M21
  13:19:56:787 : Board       : NUCLEO-L432KC
  13:19:56:787 : Voltage     : 3.27V
  13:19:56:787 : Error: No STM32 target found! If your product embeds Debug Authentication, please perform a discovery using Debug Authentication
  13:19:56:802 : Disconnected

 

Tried flashing with various modes e.g. under reset, also tried flashing with CubeIDE with OpenOCD

4 REPLIES 4
Issamos
Lead II

Hello @yaak_d3v 

According to the UM1956, ST-LINK is not powered when using 5V or 3.3V power supply.

Screenshot_2023-09-18-12-59-14-99_e2d5b3f32b79de1d45acd1fad96fbb0f.jpg

 best regards.

II

My colleague managed to flash the board a couple of times(it was very unstable), but we couldn't figure out a difference in our configuration. Also the next paragraph says: 

yaak_d3v_0-1695040102544.png

 

If you are using+5v mode then why you have removed SB9 and SB14. You have to do this in case you are using 3v3.

Best regards.

II

Do you have other means of connecting?

Say a serial port, where you could create a loader/monitor capable of delivering a .HEX or .BIN and writing the new code to the application area?

Tips, buy me a coffee, or three.. PayPal Venmo Up vote any posts that you find helpful, it shows what's working..