cancel
Showing results for 
Search instead for 
Did you mean: 

STLINKv2 vs STLINK /V2 ISOL difference

prudhvichitturi
Associate II

hi all, 

I am using STLINK/V2 ISOL which says ST_LINK, No MCU device found, just replacing with STLINK/V2 works keep all setup intact.

what could be the reason.

prudhvichitturi_0-1694695008217.png

 

1 ACCEPTED SOLUTION

Accepted Solutions

UM1075, Table 4, Vdd + GND :

AScha3_0-1695031181320.png

 

If you feel a post has answered your question, please click "Accept as Solution".

View solution in original post

8 REPLIES 8
Issamos
Lead II

Hello @prudhvichitturi 

Are you sure your STLINK/V2 ISOL is the official ST product ( is an original STLINK). It may be a replica.

Best regards.

II

Foued_KH
ST Employee

Hello @prudhvichitturi , 

Did you check this user manual : ST-LINK/V2 in-circuit debugger/programmer for STM8 and STM32 - User manual?

Could you please verify your hardware configuration ?

Foued

To give better visibility on the answered topics, please click on Accept as Solution on the reply which solved your issue or answered your question.

The STLINK/V2 ISOL is a ST official product.

Foued

To give better visibility on the answered topics, please click on Accept as Solution on the reply which solved your issue or answered your question.

Hello @Foued_KH and thank you for your feedback.

I'm sure that it is an ST official product. I just mean that the one STLINK that @prudhvichitturi  is using maybe a bad cloned copie of the original STLink as in this post.

Best regards.

II

prudhvichitturi
Associate II

i bought it from RS , I think it is an official product. I am using stm32L051rz.

It flashes fine with ST-LINK/V2 , but not with ISOL.

AScha.3
Principal III

your target is powered ? because st-link isol has no power output , st-linkV2 has power out.

so check voltage on your L05 board, when using  st-link isol .

If you feel a post has answered your question, please click "Accept as Solution".
prudhvichitturi
Associate II

Ok , that might be the difference, i thought both are the same apart ISOL. i will check it again. could you please point out the power out difference in the datasheet.

UM1075, Table 4, Vdd + GND :

AScha3_0-1695031181320.png

 

If you feel a post has answered your question, please click "Accept as Solution".