Showing results for 
Search instead for 
Did you mean: 

Brand new STM32F769I-DISCO board showing black screen

Associate II

Have just purchased a F769I disco board and upon powering it up both by the USB stlink connector with the stlnk power jumper enabled and a PoE injector with the poe5v power jumper enabled, the board has the "PWR" LED lit and the "COM" LED is blinking red but nothing seems to be shown on the screen. 

From what I've read, this board should come pre-programmed with some demos, so was expecting this to jump straight into a demo firmware like I've seen with other boards. Or is it just a "blink the LED" demo that I'm seeing.

Just wanting to check if this is usually the case for these boards, or if I'm missing some obvious step here, before trying to start programming it with my own code.

Oddly the test sticker on the board has T1-T4 all ticked, but no tick on the QA box. 

ST Employee

Hi @Wol  ,

The discovery board should be programmed with a live demo by default, I can check internally. 
Please could you provide me the exact board name (MBXXXX) and the revision?
If you did not device the board with your own, on your side what can be interesting is to see on STM32CubeProgrammer if the device is flashed by looking on its memory. 

Best regards,

Associate II

Thanks for the reply!

The board is MB1225-F769I-B03 with the MB1166 Rev A display board.

It appears when connecting it to STM32CubeProgrammer and I can read the memory out of it seemingly.

0x00000000 is 0x58306F8E (I can read up to 0x3FFF fine)

0x00100000 starts 0x20003420 (see attached) which is BOOT_ADD1

0x00200000 is just 0xFFFFFFFF which is BOOT_ADD0

0x80000000 is 0x00000000

0x90000000 is also 0x00000000


Is there a hex file for the default application which I can flash onto the device just to check it works before adding in the unknowns of getting my build environment setup?

Associate II

Also to add, that BOOT0 seems to be low on the board according to the schematic, so I'm not sure if it's trying to boot from 0x00200000 which doesn't have anything at it?

ST Employee

Hi @Wol ,

Sorry for the delay, I tried to reply directly on this post but due to size constraint I could not add the binaries files.
Here is how to download them :
  - Please refer to the :
  - Go to "Tools & Software"
 - At the end of the page you will find "Binary resources" and the "compiled demos"


Best regards,


Associate II

Thanks for the link! Have managed to download that and followed the readme provided to enable the external loader for the board, erase the internal and external flash, and now the board at least boots up and displays the "life augmented" tagline and the ST logo on the display, but that's as far as the demo gets and nothing happens further. Tapping the screen doesn't get anything, and the user button doesn't do anything. 

The hex file seemed to program okay and then verify successfully too: 

11:23:01 : Memory Programming ...
  11:23:01 : Opening and parsing file: STM32769I-DISCO_DEMO_V1.0.0_FULL.hex
  11:23:02 :   File          : STM32769I-DISCO_DEMO_V1.0.0_FULL.hex
  11:23:02 :   Size          : 43607875 Bytes
  11:23:02 :   Address       : 0x08000000 
  11:23:02 : Erasing memory corresponding to segment 0:
  11:23:02 : Erasing internal memory sectors [0 6]
  11:23:05 : Erasing memory corresponding to segment 1:
  11:23:05 : Erasing internal memory sectors [8 9]
  11:23:07 : Erasing memory corresponding to segment 2:
  11:23:07 : Erasing internal memory sectors [10 11]
  11:23:09 : Erasing memory corresponding to segment 3:
  11:23:09 : Erasing external memory sectors [0 130]
  11:23:29 : Erasing memory corresponding to segment 4:
  11:23:29 : Erasing external memory sectors [256 714]
  11:24:37 : Erasing memory corresponding to segment 5:
  11:24:37 : Erasing external memory sectors [768 818]
  11:24:45 : Download in Progress:
  11:29:40 : File download complete
  11:29:40 : Time elapsed during download operation: 00:06:38.290
  11:29:40 : Verifying ...
  11:29:40 : Read progress:
  11:34:29 : Download verified successfully 
  11:34:29 : RUNNING Program ... 
  11:34:29 :   Address:      : 0x08000000
  11:34:29 : Application is running, Please Hold on...
  11:34:29 : Start operation achieved successfully

 This is the info about the target board in STM32CubeProgrammer which all looks okay to me. Annoyingly the UI hides some of the text behind "..."s. It shows that the external loader is there and it's found the parts okay. 


The readme did say that for the media demos that I need to connect a USB stick with the provided media files on it, but I've had another dev kit board which still boots into the usual list of apps without needing this plugged in. 

Are there any steps I'm missing in getting this board to work? Even doing a full chip erase first doesn't seem to have changed anything either. 


I have the same problem: STM32F769I-DISCO did not come pre-programmed. I tried to program the STM32F769I-DISCO with the precompiled HEX file (STM32769I-DISCO_DEMO_V1.0.0_FULL.hex) like it was described in the readme.txt. Programming was about 5min. Only the ST Logo was visible. But no demo runs.