Showing results for 
Search instead for 
Did you mean: 

Connect to the cloud with STWINKT1B

Associate II

Hello everyone,

I have been trying to use the STWINKT1B board for predictive maintenance for months, but I have encountered numerous difficulties.

As a first step I carefully followed the following guide:

Therefore, I installed the FP-AI-PREDMNT2 firmware, downloaded the app and tried to download the required certificates using ST BLE Sensors.

Unfortunately I didn't get the desired result, in fact trying to download the certificate I received the message "[502] device (device ID) already exists", but no certificate or device appeared under the "Predictive Maintenance" list.

At this point I tried to start over by following the instructions in the manual below (page 64, 4.4.2 Predictive Maintenance cloud application):

Here it is instructed to download the FP-AI-PREDMNT1 firmware (and not FP-AI-PREDMNT2) and enter the certificates using Tera Term.

I downloaded the certificates from the DSH-PREDMNT dashboard and saved the IoT endpoint.

I have the STEVAL-STWINWFV1 Wi-Fi expansion and the board connects to the network correctly.

However, when I try to get the board to connect using TeraTerm according to the instructions described, I get the error below:


Frankly, I have no idea how to fix it, so I really hope you can point me to a solution.

ST Employee

Hi @SSeas​ ,

Please refer to your OLS ticket #00158255.

Please check that:

  • FP-AI-PREDMNT2 configures the board through the app. Which version of app and operating system they are using? Consider that PREDMNT2 is supported by the 4.12 version of ST BLESensor on Android and by 4.15 on iOS. With previous versions, PREDMNT2 cannot be used.

  • The reported error: [502] device (device ID) already exists. The dashboard no longer admits devices with the same name. If you want to do a clean test again, you should first delete all devices from the DSH-PREDMNT database.

  • FP-AI-PREDMNT1 does not exist. Probably you are referring to FP-IND-PREDMNT1. In our opinion it hasn't uploaded the certificates. In the TeraTerm log you did not press the USR button, as indicated. Try to do it all over again, redoing the whole configuration by pressing USR every time it is requested and show us the complete log.

  • Last thing: The network you are connecting to must be 2.4GHz. The module does not support 5GHz wi-fi.


Associate II

I have tried several times to delete the device from the Dashboard, but as soon as I update the page, the device is again associated with my account.

I have verified that my network is 2.4GHz, so I can confirm that.

Clearly I pressed the USR button to insert the certificates, below I report the complete log:






Hi @SSeas​ ,

The OLS should be managing your request (OLD ticket #00158255).

Please report here the solution, in case.