cancel
Showing results for 
Search instead for 
Did you mean: 

STM32F030F4P6 programming

NİHAT_EEE
Associate II

Hi, I have a problem about upload program. I make size photocell with STM32F030F4P6 MCU. After I set hardware and software, I can not upload programming to MCU. I try to upload programming with ST-LİNK V2. And writing problem at console. Error is that ;

Target no device found

Error in initializing ST-LINK device.
Reason: No device found on target.

What can I do?I control connection pinout. Coming 3.3V and connection pinouts is correct. Please Can you give advice?

Thank you.

6 REPLIES 6
Peter BENSCH
ST Employee

Welcome @NİHAT_EEE, to the community!

Is your ST-LINK/V2 in a colourful metal box?

Regards
/Peter

In order to give better visibility on the answered topics, please click on Accept as Solution on the reply which solved your issue or answered your question.
AScha.3
Principal III

do you have any other STM board or discovery board , to test : connect and working with CubeProgrammer ?

 

If you feel a post has answered your question, please click "Accept as Solution".

Yes, it is colourful metal box.

Yes, I try cube programmer and ST-link V2 at breadboard. İt is working both of them.

so on your breadboard its ok, you can program the cpu ?

then you have some bad or wrong connection to your target board. 

boot0 low ?

connect mode : " software reset "

 

If you feel a post has answered your question, please click "Accept as Solution".

I dont use crystal my target board. I just use stm32f030f4p6 MCU. İt is not modüle.