Showing results for 
Search instead for 
Did you mean: 

STM32CubeProgrammer not working, starting up and then closing immediately

Associate II

I've been using the programmer for a couple of week now and everything seemed to work fine.

When I powered up my pc and tried to run the program I got a starting screen that quickly disappeared. This happened even after I reinstalled the program, anyone has had this problem and knows how to solve it?

Associate II

Oops.. Just saw a post about JDK. Deinstalled it, and now it works

Associate III

I am experiencing the same problem using Windows 7. I updated my Java to version 1.8.241 and then installed the STM32CubeProgrammer software. Per previous posts, I examined the .installtioninformation file and found that JAVA_HOME points to the Program Files folder containing the newly installed version of Java. However, the problem persists. I did notice that one of the posts referred to the Java SDK which is not installed. This is very frustrating so any help would be appreciated.

Did you see the other post in my comment above? Do you have any Java 9's installed in your 'add or remove programs'. If so try uninstall.

Also Java may be 32 or 64 bit, check you have the right one installed, or better yet install both (assuming your computer is 64 bit).

I looked at of the other posts before posting the question. I verified that there are NO Java 9's installed in my system. In fact, I searched the entire C: drive to locate any java.exe files to be certain that the STM32CubeProgrammer software was finding the correct version of Java. Unfortunately, the installer for version 2.3 of the STM32CubeProgrammer does not provide any information about the specific version of Java needed. I did invoke the version command of the Java executable and it displayed the following:

java version "1.8.0_241"

Java(TM) SE Runtime Environment (build 1.8.0_241-b07)

Java HotSpot(TM) 64-Bit Server VM (build 25.241-b07, mixed mode)

I do not have any 32-bit versions of Java anywhere in my system. It is not clear to me that the installer would be looking for the 32-bit version of Java if it already detects the latest 64-bit version.

Given that the JAVA_HOME is pointing to the proper version of Java (1.8.0_241) i.e. JAVA_HOME = C:\Program Files (x86)\Java, I am at a loss to understand what is happening. To further complicate things, I cannot find any information published by STMicroelectronics that provides any clue as to what I should be looking for!!

Seen issues with it open/close if the External Loader directory contains an STLDR it doesn't like

Tips, Buy me a coffee, or three.. PayPal Venmo
Up vote any posts that you find helpful, it shows what's working..
Associate III

As a sanity check, I tried installing the STM32CubeProgrammer software on my Windows 10 laptop. (The laptap was virgin i.e. no previous versions of Java AND it has no STM32CubeIDE loaded either which means no STLDR files.) To my surprise ... it works!! This suggests that the problem may be related to the fact that the Windows 7 desktop may be contaminated as a result of having more than 100 applications installed. That said, it still not make sense that the programmer software won't execute properly on the desktop.

I uninstalled all my Javas and re-installed 32 bit Version 8 Update 241 and got some java error after opening cubeprogrammer.
Then installed 64 bit Version 8 Update 241 and it started working again.
Try going to then downloading ‘windows offline (64 bit)’

4 months ago, we've read this:

STM32CubeProgrammer team is working to embed the JRE in its install package as STM32CubeIDE does.