Showing results for 
Search instead for 
Did you mean: 

Can't use STM32CubeIDE problem during download

Associate II


I'm new on STM32 devices and would evaluate some MCU.

I bought my eval kit, install the IDE and stuck on an error 1 minute after install ....


I have this error each time I start a new project.

I'm on Debian 12 and use the generic linux version.

Also tried in root, but same problem.

Someone can help me ? Thanks !


Mahmoud Ben Romdhane
ST Employee

Hello @Rverf.1,


First let me thank you for posing and welcome to the ST Community.

The same problem was reported at this Post.

I suggest that you delete the and close the STM32CubeIDE and reopen it. 




I haven't this file on my disk.

Checked in my home (including ~/.stmcufinder), and /opt/st/stm32cubeide_1.15.1

Associate II

Still no solution for this problem ?

2024-06-20 09:16:34,571 [INFO] LoadUrlFilesThread:156 - End of LoadUrlFiles Thread
2024-06-20 09:16:34,691 [INFO] ServerAccessManage:473 - Download File
2024-06-20 09:16:35,058 [INFO] FileExtend:240 - Unzip File :
2024-06-20 09:16:35,059 [INFO] FileExtend:255 - Standard Zip Deflate
2024-06-20 09:16:35,410 [INFO] LoadUrlFilesThread:156 - End of LoadUrlFiles Thread
2024-06-20 09:16:35,558 [ERROR] ServerAccessManage:1172 - Problem during Server Connection :  IO error Connexion refusée
2024-06-20 09:16:35,559 [ERROR] ServerAccessManage:651 - Problem during Server Connection :  :

Terminal output. It's ok for other files but not this one