cancel
Showing results for 
Search instead for 
Did you mean: 

STM32cubeIDE cannot find usb_device.h file even after re-installing and including path in settings

Jeet
Associate

Greetings,

 

I am developing code for USB device and I just started interfacing USB in STM32cubeIDE. After configuring settings in .IOC file, I generated the code without any error. 

However, while building the program it shows below mentioned error. after some quick server I found this post. I tried including path in properties > settings. Also, I just downloaded latest version and did not used any old versions before. I also re-installed the software but it does not work at all. 

 

Jeet_0-1711693962268.png

 

Even after creating whole new project. It does not work. My repository settings are already default and did not changed at all. 

Please help me. I cannot think of anything and tried whatever I found or suggest any other suggest to make it work. maybe other compilers or something else.

 

Thank you so much for your efforts in advance

 

1 REPLY 1
Mahmoud Ben Romdhane
ST Employee

Hello @Jeet ,

 

First let me thank you for posting and welcome to the ST Community.

Further to your comment, I download your ioc and load it on STM32CubeMX 6.11.0 and build it on STM32CubeIDE 1.15.0.

The Firmware Package : STM32Cube FW_L0 V1.12.2.

The compilation error was not reproduced by my side.

 

Thanks.

Mahmoud.