Showing results for 
Search instead for 
Did you mean: 

SFR view crashes STM32CubeIDE


Whenever I try to use the SFR view window, it consistently crashes the IDE. Completely hangs up, not responding to anything (e.g. resizing the window) anymore.. left it sit for 15min (way too long) no responsiveness.

I can easily reproduce this by launching a debug session, and then e.g. trying to unfold "NVIC" item in the SFR listings. => IDE hangs

Also starting to type so I can narrow down the amount of entries in the panel => IDE hangs

Typing "NVIC" somewhere else first, then copy-pasting it into the field (so it doesn't first go searching for everything with "N" in the name, and then having to read a few hundred registers) => IDE hangs

I'm using STM32CubeIDE 1.13.0, installed last week. The target is a STM32U575 on a nucleo. None of my user code is running yet, because its still halted at the entry of main. I've not touched any of the debugger settings w.r.t. to the onboard STLink.

OS is Manjaro Linux with all up to date packages.

Please advice, as this makes developing for this chip very hard.


I've just verified the debug connection is stable and operational in CLion + openocd 0.12.0+dev-00274-g7023deb06-dirty (nightly build) + system arm-none-eabi-gdb 13.1.

I'm able to debug the chip with an Embedded GDB server profile pointed to the ELF file produced by STM32CubeIDE, debug the CPU with sourcecode view,  SVD file and browse the NVIC registers etc. So it seems to me that the problems are within STM32CubeIDE.


Im having the same issue while trying to use the SFR view. Im developing on a U545 Nucleo board using an ST-LINK/V2 and everytime I try to type in the search bar or open a dropdown in SFR the entire IDE completely freezes.

I think I found a work around for this. If you click on the "RTOS Proxy" or "ST-LINK" before opening a drop down or searching then open the register that you want the IDE will not hang. I believe this is because the IDE is trying to load all of the register values normally, but when you have the "RTOS Proxy" selected there are no register values to load so no hang. There is absolutely a bug in the IDE connected to loading the register values when a dropdown or search triggers the mass read of all registers in a register grouping, at least where the U5 series is concerned.

Associate III

I'm seeing the same behaviour for the G4 with v1.13.2 under MacOS.

Associate II

The same behvour with both Nucleuo U545 and with ST-LINK V3MINIE connected "swd" to custom board U535. I'm using IDE Version: 1.13.1 under Windows 7 Pro SP.1

After completing 20 lessons of a tutorial, I started having this problem with any tutorial. I then configured Debug for Shared ST_Link. Problem disappeared. I then unset Shared ST_Link and SFR  operated correctly for a while without problem BUT then the problem recurred. Setting Shared ST_Link again fixed the problem but on initializing debug I get the messages: 

Info : default port : 7184

Info : Remote address:

Info : stlinkserver already running, exit

Associate III

I've found that interaction with the SFR view (searching, expanding a node) does not cause a hang if execution is paused (at a breakpoint or hit "pause"). This is generally the case for me as I'm normally waiting for a breakpoint to be hit, but it is frustrating when I forget to hit "pause" when that's not the case!

Yes, that seems a solution. I just tried it on a few breakpoints and step-overs on two different projects and it worked fine.

Thanks for that tip.